Implement GetEvictionOffset for WebM reader.

RESOLVED FIXED in mozilla34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kinetik, Assigned: kinetik)

Tracking

(Blocks 1 bug)

unspecified
mozilla34
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Attachment #8469826 - Flags: review?(cajbir.bugzilla)
(Assignee)

Updated

5 years ago
Blocks: MSE
Depends on: 1049133
(Assignee)

Comment 2

5 years ago
Fix a silly compile error. :-|
Attachment #8469826 - Attachment is obsolete: true
Attachment #8469826 - Flags: review?(cajbir.bugzilla)
Attachment #8469861 - Flags: review?(cajbir.bugzilla)

Comment 3

5 years ago
Comment on attachment 8469861 [details] [diff] [review]
Implement GetEvictionOffset for WebM reader. v2

Review of attachment 8469861 [details] [diff] [review]:
-----------------------------------------------------------------

::: content/media/webm/WebMBufferedParser.h
@@ +199,5 @@
>  
>    void NotifyDataArrived(const char* aBuffer, uint32_t aLength, int64_t aOffset);
>    bool CalculateBufferedForRange(int64_t aStartOffset, int64_t aEndOffset,
>                                   uint64_t* aStartTime, uint64_t* aEndTime);
> +  bool GetOffsetForTime(uint64_t aTime, int64_t* aOffset, bool aSyncPoint);

Remove the boolean parameter and make it an enum of some sort. Add a comment explaining what it is.
Attachment #8469861 - Flags: review?(cajbir.bugzilla) → review+
(Assignee)

Comment 4

5 years ago
Address review comments, carry forward r+
Attachment #8469861 - Attachment is obsolete: true
Attachment #8470576 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/1150a58d8b3a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34

Comment 7

5 years ago
This patch breaks seeking on the youtube demo page.  If I revert this patch then seeking works again. I've raised bug 1054970 for this.

Comment 8

5 years ago
Posted image yt seekbar
Is this caused by this bug?

Comment 9

5 years ago
Ugh. Meant to post it in Bug 1054970.
(Assignee)

Updated

5 years ago
Depends on: 1054970
You need to log in before you can comment on or make changes to this bug.