Persona authentication gets out of sync with the django session

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mdoglio, Assigned: mdoglio)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
I still notice that sometimes the authentication status in the UI gets out of sync with the one in the django session.
(Assignee)

Updated

4 years ago
Blocks: 1042695
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 1

4 years ago
The login status doesn't persist anymore on the client. A check is instead done via ajax on page load.
(Assignee)

Comment 2

4 years ago
Created attachment 8470918 [details] [review]
Github PR #124  on treeherder-ui
Assignee: nobody → mdoglio
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Priority: -- → P1
Blocks: 1030636
(Assignee)

Updated

4 years ago
Blocks: 1048347
No longer blocks: 1048347
Duplicate of this bug: 1048347

Comment 4

4 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/f598b1d5367acfc89cbacbccc4024c5fe72d8c0c
(bug 1050765) fix persona getting out of sync

https://github.com/mozilla/treeherder/commit/648458fb67c002b8cdd32817bf4932e63c14e184
Merge pull request #124 from mozilla/bug-1050765-persona-out-of-sync

(bug 1050765) fix persona getting out of sync
You need to log in before you can comment on or make changes to this bug.