Problem of jpeg image 'vibration' when used in background-image in cover size with 2 or more divs with differents sizes

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: j.berenguier, Unassigned)

Tracking

({power, regression})

31 Branch
x86_64
All
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox33+ wontfix, firefox34+ wontfix, firefox35 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; rv:11.0) like Gecko

Steps to reproduce:

Create two on more divs with background-size: cover, and different sizes
Use THE SAME IMAGE in every div
Juste see sample


Actual results:

The image... vibrates


Expected results:

No vibration
(Reporter)

Updated

5 years ago
Summary: Problem of jpeg image 'vibration' when used in background-image in cover size with 2 or more divs with différents sizes → Problem of jpeg image 'vibration' when used in background-image in cover size with 2 or more divs with differents sizes
I don't see any motion on an OS X nightly build. What should I be looking for in particular?

Comment 2

5 years ago
(In reply to Josh Matthews [:jdm] from comment #1)
> I don't see any motion on an OS X nightly build. What should I be looking
> for in particular?

I think it's only on Windows, I see the bug. Check the screencast.
(Reporter)

Comment 3

5 years ago
This picture shows the two states of the "vibration" on the top small pictures.
Left view : pixixelized state
Right view:  correct state

Comment 4

5 years ago
It's probably an issue about image rastering.

Regression range:
good=2014-06-17
bad=2014-06-18
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bb35d1b73634&tochange=37f08ddaea48

Speculative bug maybe:
George Wright — Bug 913805 - Hold a lock on the RasterImage in ScaleRequest so that the srcFrame doesn't go away if we need to discard images to free up memory r=seth
I dont have any access so I dont know if this bug has been backported from FF33 to 31.
Component: General → ImageLib

Comment 5

5 years ago
[Tracking Requested - why for this release]:regression of visual glitch

[Tracking Requested - why for this release]:regression of visual glitch

setting image.high_quality_downscaling.enabled = false helps high CPU usage and vibration.

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=67f48cc4e6c9&tochange=0f2821706cdb

	0f2821706cdb	George Wright — Bug 913805 - Hold a lock on the RasterImage in ScaleRequest so that the srcFrame doesn't go away if we need to discard images to free up memory r=seth



I think that Mozilla should disable image.high_quality_downscaling.enabled until fixing bug 977459.
Status: UNCONFIRMED → NEW
Depends on: 977459
Ever confirmed: true
George, does it a bell?
FYI, I am experiencing the same issue under GNU/Linux.
Flags: needinfo?(gwright)
OS: Windows 8.1 → All
I don't think this is related to bug 913805. Seth might have more of an idea.
Flags: needinfo?(gwright) → needinfo?(seth)
Tracking because it is a regression and it might hide some bigger issue.

Alice, could you explain me why you added the power keyword? Thanks
Flags: needinfo?(alice0775)

Comment 9

5 years ago
(In reply to Sylvestre Ledru [:sylvestre] from comment #8)
> Tracking because it is a regression and it might hide some bigger issue.
> 
> Alice, could you explain me why you added the power keyword? Thanks

Because, CPU 100% usage.
Flags: needinfo?(alice0775)
Alice0775 White is 100% correct: this will be fixed by bug 977459. It doesn't hide some bigger issue. This is basically how things are designed to work, it's just a very bad case for the current algorithm.

I currently don't think it's worth disabling HQ downscaling, because right now we are extremely close to fixing bug 977459. If that gets delayed, though, maybe it would be worthwhile.
Flags: needinfo?(seth)
I've decided to split bug 977459 into multiple smaller bugs. This will be resolved by bug 1060200, which I'm uploading a patch for now.
Depends on: 1060200
No longer depends on: 977459
Seth, are you planning to ask for an uplift in bug 1060200? If it is the case, it should arrive asap since we are in the middle of the beta cycle.
Flags: needinfo?(seth)
(In reply to Sylvestre Ledru [:sylvestre] from comment #12)
> Seth, are you planning to ask for an uplift in bug 1060200? If it is the
> case, it should arrive asap since we are in the middle of the beta cycle.

No, it can't be uplifted. It depends on a *lot* of stuff - it took a massive refactoring to make this fix possible. Unfortunately we'll need to wait for this to ride the trains normally.
Flags: needinfo?(seth)
OK. Thanks for the feedback Seth!
Can we close this bug then?
(Reporter)

Comment 15

5 years ago
Yes :)

Comment 16

5 years ago
Is it fixed in the daily Nightly?
It's fixed on m-c, and if it's not in today's Nightly it'll be in tomorrow's.

Sylvestre, let's leave this bug open until tomorrow; I'll close it then. I want to let bug 1060200 settle for 24 hours or so to make sure we don't need to back it out. It's a *big* change and regressions are very possible.

Comment 18

5 years ago
Fixed for me in the latest Nightly.
OK, it looks like bug 1060200 is going to stick. Let's resolve this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(seth)
Resolution: --- → FIXED
Reproduced the original issue using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-09-03-07-20-57-mozilla-central/

Once I reproduced the issue using the poc from comment #0, I went through the following verification:

- Windows 8.1 x64 - (VM) - PASSED (reproduced and verified)
- Windows 7 x64 - (VM) - PASSED (reproduced and verified)
- Ubuntu 13.10 x64 (VM) - PASSED (reproduced and verified)

- ensured that the poc from comment #0 worked on regular windows/tabs
- ensured that the poc from comment #0 worked on private windows/tabs
- ensured that the poc from comment #0 worked on e10s windows/tabs
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.