Closed Bug 1051006 Opened 5 years ago Closed 5 years ago

install addon doorhanger notifications not displaying

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set

Tracking

(seamonkey2.30+ fixed, seamonkey2.31+ fixed)

RESOLVED FIXED
seamonkey2.31
Tracking Status
seamonkey2.30 + fixed
seamonkey2.31 + fixed

People

(Reporter: kevink9876543, Assigned: iann_bugzilla)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Iron/31.0.1700.0 Chrome/31.0.1700.0 Safari/537.36

Steps to reproduce:

SeaMonkey 2.31 built from c-c rev 53be54f7311a / m-c rev 5e74101ce59e
new profile

Try to install NoScript latest development build from the link at
http://noscript.net/getit#devel


Actual results:

Nothing.  This gets logged to the Error Console:

Error: installInfo.originatingWindow is undefined
Source File: chrome://communicator/content/bindings/notification.xml
Line: 377

The only way to install that addon from that link is to download it with "Save Link Target As...", then drag&drop it into the SeaMonkey window.


Expected results:

I should have been presented with a doorhanger notification asking whether I wanted to install the software.
OS: Windows 7 → Linux
On current trunk I get messages like:
Timestamp: 31/08/14 22:29:13
Error: installInfo.originatingWindow is undefined
Source File: chrome://communicator/content/bindings/notification.xml
Line: 401
Timestamp: 31/08/14 22:29:16
Error: installInfo.originatingWindow is undefined
Source File: chrome://communicator/content/bindings/notification.xml
Line: 383
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looks like this was broken by Bug 952201 and landed on what is current m-a.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #8481985 - Flags: review?(neil)
Component: General → UI Design
OS: Linux → All
Hardware: x86 → All
Comment on attachment 8481985 [details] [diff] [review]
Switch from originatingWindow to originator [Checked in: Comment 5]

r=me by code inspection.
Attachment #8481985 - Flags: review?(neil) → review+
Comment on attachment 8481985 [details] [diff] [review]
Switch from originatingWindow to originator [Checked in: Comment 5]

[Approval Request Comment]
Regression caused by (bug #): bug 952201
User impact if declined: Not able to install add-ons
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #8481985 - Flags: approval-comm-aurora?
Comment on attachment 8481985 [details] [diff] [review]
Switch from originatingWindow to originator [Checked in: Comment 5]

http://hg.mozilla.org/comm-central/rev/6db6e229ea45
Attachment #8481985 - Attachment description: Switch from originatingWindow to originator → Switch from originatingWindow to originator [Checked in: Comment 5]
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.31
Duplicate of this bug: 1080526
Comment on attachment 8481985 [details] [diff] [review]
Switch from originatingWindow to originator [Checked in: Comment 5]

(In reply to Ian Neal from comment #4)
> Comment on attachment 8481985 [details] [diff] [review]
> Switch from originatingWindow to originator [Checked in: Comment 5]
> 
> [Approval Request Comment]
> Regression caused by (bug #): bug 952201
> User impact if declined: Not able to install add-ons
> Testing completed (on m-c, etc.): locally
> Risk to taking this patch (and alternatives if risky): none
> String changes made by this patch: none
Please land on comm-beta 2.30b2 ASAP.
Attachment #8481985 - Flags: approval-comm-beta+
Attachment #8481985 - Flags: approval-comm-aurora?
Attachment #8481985 - Flags: approval-comm-aurora-
You need to log in before you can comment on or make changes to this bug.