Run `make test-perf` against the Marketplace

RESOLVED DUPLICATE of bug 1037140

Status

Firefox OS
Gaia::PerformanceTest
RESOLVED DUPLICATE of bug 1037140
4 years ago
4 years ago

People

(Reporter: clouserw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
From an email conversation:  we should enable make test-perf for the Marketplace so we start seeing results in datazilla.  Thanks.
Hub, what needs to be done to get 'make test-perf' working with the Marketplace app?
Flags: needinfo?(hub)
The requirement for an internet connection to have any meaningful testing is what stopped us here. Otherwise everything seems to be in place.

I haven't had that email conversation.

Maybe Eli knows more.
Flags: needinfo?(hub) → needinfo?(eperelman)

Comment 3

4 years ago
We originally filed an issue for this, but according to [1], Marketplace needed to be packaged in order to have access to an internet connection during testing. I haven't followed up to see what it would take to get Marketplace an internet connection, but we can continue that conversation over there.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1037140#c1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(eperelman)
Resolution: --- → DUPLICATE
Duplicate of bug: 1037140

Comment 4

4 years ago
Just to be clear, everything else in make test-perf already allows the Marketplace to be tested, we are just blocked by having an internet connection, which is either an infrastructure decision or a packaging decision, from what I understand.
We only run 'make test-perf' on real hardware, which can at least be configured to have a wifi connection.
You need to log in before you can comment on or make changes to this bug.