[verticalhome] TypeError: this.grid._grid.dragdrop is undefined

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: djf, Assigned: kgrandon)

Tracking

unspecified
2.1 S2 (15aug)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This error message can appear in the logcat, at least in version 2.0 I saw it first in bug 1050751

I traced it to app.js:200. The dragdrop module is lazy loaded, so it is possible for that code to run before the dragdrop property is defined.   This is pretty obviously just a case where you need to test for its existance before using it.

I can reproduce the error by launching an app, using adb shell kill to kill the homescreen and then rapidly tapping multiple times on the home button.  This launches a new homescreen and then triggers that app.js:200 code before the lazy load is done.

_grid.dragdrop is also used without checking in the context menu code, but I didn't try to cause an error there.
(Assignee)

Comment 1

3 years ago
This should not cause any problems, but we should definitely fix it. Thanks for filing.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S2 (15aug)
(Assignee)

Comment 2

3 years ago
Created attachment 8470307 [details] [review]
Github pull request

David - any chance you'd be willing to throw a review stamp on this since you reported it? :)
Attachment #8470307 - Flags: review?(dflanagan)
Attachment #8470307 - Flags: review?(crdlc)
(Assignee)

Updated

3 years ago
Blocks: 1048639
(Assignee)

Comment 3

3 years ago
Comment on attachment 8470307 [details] [review]
Github pull request

Hey Chris - any chance you have some cycles for a review? Thanks!
Attachment #8470307 - Flags: review?(chrislord.net)
(Assignee)

Comment 4

3 years ago
[Blocking Requested - why for this release]: This is needed to help us solve bug 1048639 (a CAF blocker).
blocking-b2g: --- → 2.0?

Comment 5

3 years ago
Comment on attachment 8470307 [details] [review]
Github pull request

LGTM + points for test :)
Attachment #8470307 - Flags: review?(chrislord.net) → review+
(Reporter)

Comment 6

3 years ago
Comment on attachment 8470307 [details] [review]
Github pull request

This looks good to me. I've noted a few nits on github, but nothing that I feel needs to be fixed.

Consider adding a similar fix in the contextmenu event case in contextmenu_handler.js before landing.
Attachment #8470307 - Flags: review?(dflanagan) → review+
See comment 4
blocking-b2g: 2.0? → 2.0+
(Assignee)

Comment 8

3 years ago
Comment on attachment 8470307 [details] [review]
Github pull request

Thanks for the review guys. I'm making some minor updates to the code based on David's comments and will land this.
Attachment #8470307 - Flags: review?(crdlc)
(Assignee)

Comment 9

3 years ago
Master: https://github.com/mozilla-b2g/gaia/commit/c9b9925202c1419de201871fe40a431d41b50490
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
v2.0: https://github.com/mozilla-b2g/gaia/commit/33123f5e8717b5001622a0f53ae4f90b5890f34d
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
attachment 8470307 [details] [review] has been landed in AU63
You need to log in before you can comment on or make changes to this bug.