prompt for app-specific password hangs with spinner rather than taking new password

RESOLVED WONTFIX

Status

Firefox OS
Gaia::E-Mail
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: dbaron, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Reporter)

Description

4 years ago
I recently switched one of my google accounts to use two-factor auth.  This account had been set up in my Firefox OS email client.

When I started the email client just now (although it's actually been a day since I did this, and I've used the email client other times), it prompted me that I needed to enter an app-specific password for this account, and gave me a prompt to enter the password.  This was very helpful.

However, when I switched to that account's folder, it then just had the spinner spinning as though it was trying to connect.

If I then killed the email app through the cards view and started it again, it gave me the same prompt, and entering the app-specific password again led to the same spinner.

Ignoring the helpful UI, clicking the settings gear icon, and going to directly change the password for the account worked, though.  So something seems to be wrong with this otherwise-very-helpful prompt that prevents it from working.

I'm using a Flame running v122 base image plus fonts plus
gaia 2d2475b521351e200136e463358e6c8e91957702
gecko a6424bfa8f39 plus my local patches as of Fri Aug 08 16:43:07 2014 -0700
in a self-built user build.
(Reporter)

Updated

4 years ago
Summary: prompt for app-specific password hangs with spinner rather than taking new pas → prompt for app-specific password hangs with spinner rather than taking new password
This is a regression from bug 805501 where we introduced support for using different credentials for IMAP versus SMTP.  setup_fix_gmail_twofactor just reuses setup_fix_password's logic.  When setup_fix_password gained the "whichSide" parameter to indicate if we were talking about IMAP/SMTP, the way the if/else was structured means that if omitted we assume we're talking about SMTP.  We didn't upgrade two-factor to specify it, so sadness.

As a result we were likely correcting your SMTP password but not your IMAP password.

This is a case where front-end specific integration tests would have caught it, so mucho mea culpa for that whole snafu.  Marking a dependency on me turning those on again, bug 975588.

We'll ideally want the fix uplifted to v2.0 to erase this from history.  Super low risk.
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Depends on: 975588

Comment 2

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.