Closed Bug 1051181 Opened 5 years ago Closed 5 years ago

(In e10s window) Address bar of last tab created never gets auto-focus (neither upon creation, nor when selected thereafter)

Categories

(Firefox :: Tabbed Browser, defect)

34 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1050447

People

(Reporter: adrien.guerard, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140808030201

Steps to reproduce:

Open a new e10s window in Nightly 34.0 on Mac OS X 10.9.4
Create new Tab (either with cmd-T, browser-button, or by going File > New Tab)
Auto-focus will never go to address bar when selecting between that tab and any inner tabs
Create another tab, and see that now the previous one that wouldn't auto-focus, now does. 


Actual results:

The last created tab (index does not matter; for proof, drag it around and then try to get auto-focus. Furthermore, close the last one created, and you'll see all remaining tabs auto-focus fine) never gets auto-focus.


Expected results:

Whenever user navigates to any tab or creates one, the address bar is supposed to get auto-focus.
Component: Untriaged → Tabbed Browser
Blocks: fxe10s
"Auto-focus will never go to address bar when selecting between that tab and any inner tabs"
This is poorly worded; I explain the bug in the 'Actual Results' section better.
Sorry. So if you focus on the address bar in the newly created tab, it'll retain focus. So the only real bug is that the address bar doesn't get auto-focus upon creating a new tab.
Depends on: 1050447
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050447
You need to log in before you can comment on or make changes to this bug.