Crash viewing source of a '1969' bogus message.

VERIFIED DUPLICATE of bug 78785

Status

VERIFIED DUPLICATE of bug 78785
17 years ago
14 years ago

People

(Reporter: stephend, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Build ID:  2001-10-16, 0.9.4 branch.

Summary:  Crash viewing source of a '1969' bogus message.

Steps to reproduce:  Put this in a local folder, and try to view source.

Actual Results:  We crash.

Expected Results:  No crash.
I had hoped to attach the bogus message, but it's 0 bytes, so worthless, indeed.
 This bug wouldn't exist and depends on us creating the bogus message in the 1st
place.  To create the bogus message, I did a combination of copying the POP3
message in my inbox to trash, then attempted to move it to the trash.  When I
switched folders and came back to the inbox, I saw the 1969 message.

Comment 4

17 years ago
The "1969" bug (occures when date header is missing) is bug 73565

Comment 5

17 years ago
i think this one is bogus... how can a 0 byte message possibly land in the
inbox?
r.k.aa, who knows how the corruption got there.  I did my best to explain the 
scenario, but the main point is that there might need to be some code to check 
if we have some bogus portions in a message before viewing source (so at least 
we don't crash).  The message itself being bogus is another, already filed bug.

Comment 7

17 years ago
dup of bug 78785?
Indeed.

*** This bug has been marked as a duplicate of 78785 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.