Updater installs Mozilla Maintenance Service without consent

RESOLVED FIXED in mozilla36

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: krystian4842, Assigned: bbondy)

Tracking

31 Branch
mozilla36
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

I installed Firefox without Mozilla Maintenance Service.


Actual results:

When an update for Firefox came and updater ran it installed Mozilla Maintenance Service.


Expected results:

Updater shouldn't install Mozilla Maintenance Service when I didn't choose it in the installer for Firefox.

Updated

4 years ago
Component: General → Application Update
Product: Firefox → Toolkit
Is "Use a background service to install updates" in Options > Advanced > Update also checked?
Flags: needinfo?(krystian4842)
(Reporter)

Comment 2

4 years ago
I have no such option.
Flags: needinfo?(krystian4842)
(Reporter)

Comment 3

4 years ago
What I mean by that is that option is not visible at all.
What is the value (true/false) of "app.update.service.enabled" when you search for it in about:config?
(Reporter)

Comment 5

4 years ago
It's "true". I forgot to add that I've uninstalled Mozilla Maintenance Service when the updater installed it.
Duplicate of this bug: 1065415
(Assignee)

Comment 7

4 years ago
Did you install with the stub installer or the full installer originally?

I believe that we set an entry in the registry when it is specifically checked off on install, and on update it won't install it if that registry entry is set.
Perhaps this entry isn't being set correctly for the stub installer or something like that though.
Assignee: nobody → netzen
(Reporter)

Comment 8

4 years ago
I installed Firefox through stub installer with unchecking the Mozilla Maintenance Service.
(Assignee)

Updated

4 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 9

4 years ago
Created attachment 8496668 [details] [diff] [review]
Patch rev1

This sets the "Attempted" reg value so that new upgrades won't try to install the service.  Tested locally and it's working.
Pave over installs with checkbox on will still install it.
Attachment #8496668 - Flags: review?(robert.strong.bugs)
Did you figure out what changed to make this happen?
(Assignee)

Comment 11

4 years ago
No I looked back at blame history but I couldn't find a reason. 
I'm wondering if we just missed this case originally.

I thought we had this working at some point but I couldn't find a reason within a reasonable time frame.  This is the right fix IMHO though.
Attachment #8496668 - Flags: review?(robert.strong.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/2fd40580507b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.