If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Back button fails to work properly when url is typed in the address bar

VERIFIED DUPLICATE of bug 103978

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 103978
16 years ago
9 years ago

People

(Reporter: Steve Schveighoffer, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

It seems that when you type in a url, mozilla seems to forget some of the
previous urls, especially the last one used.  I have spent a few minutes trying
to characterize the problem, I will do the best I can :)

I have my home page set to a blank page.  If I click on a link in the browser,
such as "The Mozilla Organization" in the button bar, it goes there fine.  Then,
I type in an address in the button bar such as "www.cnn.com".  It goes there
fine, but now, if I click on the back button or right click in the window and
select back from the context menu, nothing happens.  If I pull down the back
button history list, the list is a little blank square.

If I visit TWO pages using the button bar "The mozilla org..." and "Latest
Builds", and then type in another address ("www.cnn.com"), the back history
seems to have forgotten the second page "Latest Builds", but does remember the
first page "The mozilla org...".  Now here's the cooky part.  If I click on
back, I go to the first page, if I NOW click on forward, I go to the SECOND page
which was forgotten originally.  If I click forward again, I go to the third
page, and now the back history is correct.

Reproducible: Always
Steps to Reproduce:
1.  Load a fresh install of mozilla 0.9.5 on a W2K machine
2. Set home page to a blank page. (don't know if this is necessary)
3. quit mozilla and restart.
4. click on the "The Mozilla Organization" link on the button bar.
5. Type in www.cnn.com in the address bar and hit enter.
6. Try using the back functionality.

-or-
perform steps 1-4 above
5. click on the "Latest Builds" link
6. type in www.cnn.com in the address bar and hit return
7. notice that if you click on back, or look at the back history, the
"mozilla.org" is the only item there.
8. click on back, then forward.
9. you will be brought to the "Latest Builds" page.
(Reporter)

Comment 1

16 years ago
OK, I found out that bug 103978 really is the same thing.  Sorry.  I also found
out that it ONLY seems to happen with www.cnn.com
(Reporter)

Comment 2

16 years ago
just to save you the trouble, I am already marking this a duplicate of 103978.

*** This bug has been marked as a duplicate of 103978 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.