Closed Bug 1051526 Opened 7 years ago Closed 7 years ago

DevTools Themes: remove padding from sidebar tabs

Categories

(DevTools :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 34

People

(Reporter: me, Assigned: me, Mentored)

References

Details

Attachments

(2 files)

Attached image screenshot.png
When I was solving Bug 1049029, I realized there is a strange padding in the sidebar tabs that makes the title to be a little bit moved to the right.

It's just one or two pixels, but when tabs are very small, it can be perceived.
Assignee: nobody → aljullu
Blocks: 916766
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
Attached patch bug1051526.patchSplinter Review
Removing some paddings the issue is solved. I'm not sure why there were those paddings, though.
Attachment #8470469 - Flags: review?(bgrinstead)
Comment on attachment 8470469 [details] [diff] [review]
bug1051526.patch

Review of attachment 8470469 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like those values were copied over from the initial creation of the shared toolbars.inc.css: https://hg.mozilla.org/mozilla-central/rev/71fcb255a8cf. The only thing I can think is if that was overriding some UA styles, but I'm not really seeing anything in toolkit/themes/*/global/tabbox.css that looks relevant.  And this looks fine, so I'd say it is good to go.
Attachment #8470469 - Flags: review?(bgrinstead) → review+
https://hg.mozilla.org/mozilla-central/rev/65615ff8eb40
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
Verified [bugday-20140813]

Explanation: 

There is no strange padding on sidebar tabs.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.