Closed Bug 1051862 Opened 5 years ago Closed 5 years ago

Can't add e.g. Mycroft search engines

Categories

(SeaMonkey :: Sidebar, defect)

defect
Not set

Tracking

(seamonkey2.26 unaffected, seamonkey2.27 unaffected, seamonkey2.28 affected, seamonkey2.29 fixed, seamonkey2.30 fixed, seamonkey2.31 fixed)

RESOLVED FIXED
seamonkey2.31
Tracking Status
seamonkey2.26 --- unaffected
seamonkey2.27 --- unaffected
seamonkey2.28 --- affected
seamonkey2.29 --- fixed
seamonkey2.30 --- fixed
seamonkey2.31 --- fixed

People

(Reporter: neil, Assigned: neil)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Bug 983920 removed the definition of the method that the Mycroft site uses to add a search engine to the browser.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8470887 - Flags: review?(iann_bugzilla)
See also bug 1055371: AMO doesn't want to install search engines into SeaMonkey because it is not "a Mozilla-based browser (like Firefox)"
See Also: → 1055371
Comment on attachment 8470887 [details] [diff] [review]
Proposed patch

r=me and a for CLOSED TREE
Attachment #8470887 - Flags: review?(iann_bugzilla) → review+
Pushed comm-central changeset cddcddb6f521.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.31
Pushed comm-central changeset 213558a41046 for the missing rename.
Comment on attachment 8470887 [details] [diff] [review]
Proposed patch

I got my approvals mixed up and accidentally checked this in without approval. Sorry about that.

[Approval Request Comment]
Regression caused by (bug #): 983920
User impact if declined: Web pages can't add search engines
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Yes, interface changes
String changes made by this patch: None
Attachment #8470887 - Flags: approval-comm-aurora?
Attachment #8470887 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8470887 [details] [diff] [review]
Proposed patch

Review of attachment 8470887 [details] [diff] [review]:
-----------------------------------------------------------------

please land on `default` on comm-release today, in order to make SeaMonkey 2.29
Attachment #8470887 - Flags: approval-comm-release+
You need to log in before you can comment on or make changes to this bug.