[B2G][Loop] User receives "Unable to retrieve link to share" when attempting to call user with no connection

RESOLVED DUPLICATE of bug 1048219

Status

Firefox OS
Gaia::Loop
RESOLVED DUPLICATE of bug 1048219
3 years ago
3 years ago

People

(Reporter: Jordan de Geus(JordanD), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-exploratory])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8471232 [details]
2014-08-11-17-18-56.png

Description:
When users sign into the Loop app and then enable airplane mode or have WiFi and Data disabled, upon calling a contact; users will see an error message stating "Loop - Unable to retrieve link to share". 

Setup: 
- Install the Loop app on a device from: https://github.com/mozilla-b2g/firefoxos-loop-client
- Make sure user has atleast one contact that contains a valid Loop email

Repro Steps:
1) Update a Flame to 20140811000210
2) Launch Loop app
3) Enable Airplane mode from Notification menu(swipe down from the notifcations bar)
4) From the Loop app, attempt to call another user

Actual:
Users receive error message stating "Unable to retrieve link to share" when attempting to call with no connection

Expected:
User receives error message stating the user lacks a connection to make the call

Environmental Variables:
Device: Flame 2.0
Build ID: 20140811000210
Gaia: de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko: 5256345f62bd
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 3/3
See attached: Screenshot and logcat attached
(Reporter)

Comment 1

3 years ago
Created attachment 8471235 [details]
logcat_20140811_1731.txt

This issue DOES OCCUR on Flame 2.1 (319mb) , Flame 2.0 (512mb) and Buri 2.1, Buri 2.0

Actual: Users will receive error message stating "Unable to retrieve link to share" with no active connection.

Flame 2.1 (319mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140811040202
Gaia: 19ed3c9e78eaf234cc08484bde6998ae21552ba5
Gecko: a9b43778f0c2
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0 (512mb)

Enviromental Variables:
Device: Flame 2.0
BuildID: 20140811000210
Gaia: de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko: 5256345f62bd
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140811013006
Gaia: 19ed3c9e78eaf234cc08484bde6998ae21552ba5
Gecko: a9b43778f0c2
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140811063003
Gaia: 9f94a78eef3a9305140c550c983871a46b0692e7
Gecko: c2636750a6a1
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

-----------------------------------------------------------

Loop app is currently not supported on 1.4

Flame 1.4 (319mb)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140811063003
Gaia: 4a662f6dd831cf6194d7ad3501b1d56ea2964a20
Gecko: c12f198b5e51
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140811000206
Gaia: 4a662f6dd831cf6194d7ad3501b1d56ea2964a20
Gecko: e1b03b2fb92e
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Flags: needinfo?(ktucker)
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048219
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.