Closed Bug 1052388 Opened 5 years ago Closed 5 years ago

Rename JS_CallHeapFooTracer() functions to JS_CallFooTracer()

Categories

(Core :: JavaScript: GC, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla34

People

(Reporter: jonco, Assigned: jonco)

Details

Attachments

(1 file)

As mentioned in the comments in bug 875872 we should rename the JS_CallHeap*Tracer() family of functions to just JS_CallFooTracer() to indicate that these are the ones to use by default, and change the ones that operate on unbarriered pointers to indicate that they are special.
Attachment #8471567 - Flags: review?(terrence)
Attachment #8471567 - Flags: review?(bugs)
Attachment #8471567 - Flags: review?(bugs) → review+
Comment on attachment 8471567 [details] [diff] [review]
bug1052388-rename-trace-apis

Review of attachment 8471567 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome!
Attachment #8471567 - Flags: review?(terrence) → review+
https://hg.mozilla.org/mozilla-central/rev/a817b58630c8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.