Unused function HasParserReturn in Parser.cpp

RESOLVED DUPLICATE of bug 1046964

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1046964
4 years ago
4 years ago

People

(Reporter: manishearth, Unassigned, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=c++])

(Reporter)

Description

4 years ago
The function `static int HasFinalReturn(SyntaxParseHandler::Node)`[1] (as opposed to `static int HasFinalReturn(ParserNode)`) isn't used anywhere. We should remove it.


 [1]: http://mxr.mozilla.org/mozilla-central/source/js/src/frontend/Parser.cpp#770
See https://bugzilla.mozilla.org/show_bug.cgi?id=1046964#c20
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1046964
You need to log in before you can comment on or make changes to this bug.