Closed Bug 1052520 Opened 6 years ago Closed 2 months ago

The url property of the page objects returned by Kuma's $children URL handler is out of date for moved pages

Categories

(developer.mozilla.org Graveyard :: Wiki pages, defect)

All
Other
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sheppy, Unassigned)

Details

(Whiteboard: [specification][type:bug])

What did you do?
================
Look at /en-US/docs/MDN/Contribute/Howto. Find the entry for "Writing interface reference documentation". Note that its URL is listed as:

https://developer.mozilla.org/en-US/docs/Project:Writing_interface_reference_documentation

But that page was moved, a long time ago, to:

https://developer.mozilla.org/en-US/docs/MDN/Contribute/Howto/Write_interface_reference_documentation

What happened?
==============
If you look at the code for the "Howto" landing page, you see that it's using a macro to build the page. Digging into the macro, you find that it calls through to the SubpagesWithSummaries macro:

https://developer.mozilla.org/en-US/docs/Template:SubpagesWithSummaries

What should have happened?
==========================
That macro gets the URL of each page it adds to the menu using the page.url property on the page object as returned by page.subpagesExpand().

So for some reason, this method is returning the original URL of the page instead of its current URL. Which is obviously not right, and generally a Bad Thing.

Is there anything else we should know?
======================================
I presume the problem is in the URL handler for $children.
I guess these pages have been moved before mid June 2014 when this had been fixed and landed with bug 967017. So, I assume this is an older move which got not re-rendered at that time. 

You can read more here: https://bugzilla.mozilla.org/show_bug.cgi?id=967017#c1

I had asked for a page regeneration a while back (which would solve this for older moves), but it wasn't an option due to the stability problems we had in bug 1012686.
Severity: normal → major
Component: General → Wiki pages
Summary: KumaScript's page.url property is returning the original URL of a page that's been moved → The url property of the page objects returned by Kuma's $children URL handler is out of date for moved pages
MDN Web Docs' bug reporting has now moved to GitHub. From now on, please file content bugs at https://github.com/mdn/sprints/issues/ and platform bugs at https://github.com/mdn/kuma/issues/.
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WONTFIX
Product: developer.mozilla.org → developer.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.