Closed Bug 1052525 Opened 8 years ago Closed 2 years ago

atk_text_get_text_at_offset sometimes returns the previous line instead of the line at offset

Categories

(Core :: Disability Access APIs, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1525631

People

(Reporter: jdiggs, Unassigned, NeedInfo)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Steps to reproduce:
1. Open the attached test case in Firefox
2. Launch the attached accessible event listener in a terminal
3. Enable caret navigation in Firefox (F7) and Down Arrow from line to line

Expected results: Each time the caret moves, the correct line at offset would be reported.

Actual results: As you arrow down to the next line, the reported line at offset is the previous line.

Note: If you delete the whitespace in the source that is between <br/> and the <span>, the bug goes away.

Jamie: can you reproduce it with IA2?

Flags: needinfo?(jteh)
Flags: needinfo?(mzehe)
Flags: needinfo?(mzehe)

This will be fixed by an upcoming patch to bug 1525631, because the root cause is the same.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1525631
You need to log in before you can comment on or make changes to this bug.