On startup: msgbox w/"Java Plug-in Configuration Warning" & CRASH

VERIFIED DUPLICATE of bug 83376

Status

defect
--
critical
VERIFIED DUPLICATE of bug 83376
18 years ago
9 years ago

People

(Reporter: seth.mccarus, Assigned: joe.chou)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

()

From Bugzilla Helper:
User-Agent: Mozilla/4.51 [en] (WinNT; U)
BuildID:    2001101117

After installing JRE 1.3.0_01 or higher, and copying NPOJI600.dll to the Mozilla
plugins directory and starting Mozilla, I get three message boxes.  The first
two are titled "Java Plug-in Configuration Warning".  The first says it "cannot
obtain proxy configuration warning from Netscape Navigator 4.5 or later -
fallback", the second says the same about NN 4.0x.  The third reports that
Mozilla.exe has crashed, and gives me the option to debug it.

Whether this is an actual bug, or simply a configuration issue, I do not know. 
But, no matter what I try (reinstalling Mozilla, different versions of the JRE,
etc.) I cannot get Java to work... so I assume something needs to be addressed!

Reproducible: Always
Steps to Reproduce:
1. Install JRE 1.3.0_01 or higher and copy NPOJI600.dll to the Mozilla plugins
directory
2. Start mozilla.exe

Actual Results:  Three message boxes culminating in a crash, as described above

Expected Results:  Mozilla should have initialized the Java plugin and run.

Installing the other JRE DLLs (NP*.dll) has no additional effect.  I can copy
NPOJI600.dll to the plugins directory after starting Mozilla, then go to
about:plugins and see it listed as 'enabled'.  However, no matter which DLLs are
present in the plugins directory, I cannot run any Java applets or view
Java-enhanced pages.
-> Oji
Assignee: asa → joe.chou
Component: Browser-General → OJI
QA Contact: doronr → pmac
Reporter: 
Have you changed Mozilla's UA string ?
Can you try JRE 1.3.1 ?

As Matti@epost.de suggested, it was a user-agent string issue.  I removed the
errant setting and Mozilla now works correctly.  Sorry for wasting everybody's
time!...
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
This bug is not invalid because Mozilla should not crash !

It's a dupe of bug 83376
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.