Homescreen doesn't come up and not able to start any apps

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: anshulj, Assigned: cyu)

Tracking

({regression})

unspecified
2.1 S5 (26sep)
ARM
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+)

Details

(Whiteboard: [CR 725352][caf priority: p2][joint-triage+])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8471797 [details]
homescreen not starting

[Blocking Requested - why for this release]:

With the recent build I am noticing that the homescreen app doesn't start at all. On clicking the home button once after the boot, the homescreen app starts. However unable to open any apps. Clicking on an app icon shows the black ground with the app icon in the center and the screen stays like that.

Gecko: f10bc818e50753b991124dab0057ada418436fd8
Gaia: fbcb01fe39cc2eed7b2860f05908521e4936a70a


Please find the log attached.
(Reporter)

Comment 1

4 years ago
In the logs I see an error Content JS ERROR at app://verticalhome.gaiamobile.org/gaia_build_defer_index.js:400 in GridItem.prototype.doRenderIcon/<: Error fetching icon [Exception... "File error: Not found"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: app://verticalhome.gaiamobile.org/gaia_build_defer_index.js :: fetchBlob/< :: line 381"  data: no] 

Not sure if this related but thought I will mention.

Updated

4 years ago
Keywords: steps-wanted
This is 100% reproducible and on current trunk?
Kevin, any ideas?
Flags: needinfo?(kgrandon)

Updated

4 years ago
Keywords: steps-wanted → qaurgent, regression, regressionwindow-wanted, smoketest
QA Contact: jmercado
This bug could not be reproduced on the latest Central Flame, B2g-inbound flame, or Mozilla-inbound flame builds.

Flame Central
Environmental Variables:
Device: Flame Master
BuildID: 20140812093515
Gaia: 02f778766521b84da0ca3e575bfe35c37f46803d
Gecko: 0c7eb00d3ef6
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Mozilla-inbound
Environmental Variables:
Device: Flame Master
BuildID: 20140812140215
Gaia: 9f35fca9d818b26c06aa6b7e5c0bef25886f8f20
Gecko: 4c995a0d9166
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

B2g-inbound
Environmental Variables:
Device: Flame Master
Build ID: 20140812124713
Gaia: 0ff9451520a8c43e5efa82081f4b39930b1bc044
Gecko: 03d09ba5eba3
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, regressionwindow-wanted

Updated

4 years ago
Keywords: smoketest
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
According to comment 3 it does not reproduce. I'm going to try to test this again.
Flags: needinfo?(kgrandon)
(Reporter)

Comment 5

4 years ago
I am still seeing the issue with the latest code from Moz central. Please try on the KK based flame devices.

Gecko:
Gaia: 70697f90527276a914bb6e2e792938380e2791bb
Gecko: d5a4ba923d691985c68c374e78aa3736ac7cb49c

Comment 6

4 years ago
QA wanted for No-jun to try.  he has a mozilla-central build running on KK flame.   No-jun, please report your investigation here.  thanks.
Flags: needinfo?(npark)
Keywords: qawanted
QA Contact: jmercado → npark
I could not reproduce this on both 289mb and 319mb flame-kk setup on master (2.1) branch.  The phone starts up to the lockscreen, and when lockscreen is unlocked, homescreen shows up.  When lockscreen is disabled, it starts to the homescreen directly.

I ran ./config.sh flame-kk and did build for gecko and gaia.

Base image used:
v162-3

Version info:
Gaia      81683ce5bf9305148c335fa810bb979941cccb22
Gecko commit 1e2086d3a6f473b2437f25a4a9226b6c2d6c2605

BuildID   20140814135057
Version   34.0a1
ro.build.version.incremental=12
ro.build.date=Tue Jul 22 17:32:24 CST 2014
Flags: needinfo?(npark)
Keywords: qawanted
Mike, could you try to reproduce it? Thx.
Flags: needinfo?(mlien)

Comment 9

4 years ago
Verify with Flame-KK + v2.1 and cannot reproduce this issue
Gaia      70697f90527276a914bb6e2e792938380e2791bb
Gecko     60b62a869a0a2e741f5b67ce4acbf608f6a7acfa
BuildID   20140814181333
Version   34.0a1
ro.build.version.incremental=12
ro.build.date=Tue Jul 22 17:32:24 CST 2014
Flags: needinfo?(mlien)
(Reporter)

Comment 11

4 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #10)
> This might be a dupe of bug 1051633.
Does seem like it. Let me try the patch in the bug 1051633 and see if that solves the problem for us.
(Reporter)

Comment 12

4 years ago
The patch in bug 1051633 doesn't seem to fix the issue for me.

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 13

4 years ago
:bajaj -- can Moz please fix this with priority. We are not able to start anything on 2.1 without this fixed.
Flags: needinfo?(bbajaj)
Whiteboard: [caf priority: p1]
(In reply to Inder from comment #13)
> :bajaj -- can Moz please fix this with priority. We are not able to start
> anything on 2.1 without this fixed.

I'll ask some one from Homescreen team to look at it and inspect the shared logs, but given we are unable to reproduce it on Flame we will need more help here.

Can you guys give Flame+2.1 a shot and see if you hit this?
Flags: needinfo?(bbajaj)

Comment 16

4 years ago
:bajaj -- this is reproducible, see comment 10.
:gwagner, apparently this happens for every launch CAF is trying to make, unlike our discussion which was, this may happen in ~2days after continuously seeing the device.

Updated

4 years ago
blocking-b2g: 2.1? → 2.1+

Updated

4 years ago
Flags: needinfo?(anygregor)
Depends on: 1051633
Flags: needinfo?(anygregor)

Comment 18

4 years ago
Anshul -- can you please try this patch and see if it helps: https://bugzilla.mozilla.org/show_bug.cgi?id=1051633#c21
Flags: needinfo?(anshulj)
FWIW I suspect this is triggered by using DMD.  If you turn that off it will probably go away.
(Reporter)

Comment 20

4 years ago
(In reply to Inder from comment #18)
> Anshul -- can you please try this patch and see if it helps:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1051633#c21

The debug patch listed above doesn't fix the issue.
Flags: needinfo?(anshulj)
Inder, Anshul - Please see comment 19. Can you confirm if these devices running DMD? If they are can we try disabling it and reproducing the issue?
Flags: needinfo?(ikumar)
Flags: needinfo?(anshulj)
Yes, we had DMD enabled and have disabled it for now to get unstuck.  Thanks for the hint.
(Reporter)

Updated

4 years ago
Flags: needinfo?(anshulj)
Assigning to Cervantes since the work in 1051633 should fix this.
Assignee: nobody → cyu

Updated

4 years ago
Whiteboard: [caf priority: p1] → [caf priority: p1][joint-triage+]
Whiteboard: [caf priority: p1][joint-triage+] → [caf priority: p1][joint-triage+][systemsfe]
Target Milestone: --- → 2.1 S5 (26sep)

Updated

4 years ago
Whiteboard: [caf priority: p1][joint-triage+][systemsfe] → [CR 725352][caf priority: p1][joint-triage+][systemsfe]

Updated

4 years ago
Whiteboard: [CR 725352][caf priority: p1][joint-triage+][systemsfe] → [CR 725352][caf priority: p2][joint-triage+][systemsfe]
Component: Gaia::Homescreen → DOM: Content Processes
Product: Firefox OS → Core
Whiteboard: [CR 725352][caf priority: p2][joint-triage+][systemsfe] → [CR 725352][caf priority: p2][joint-triage+]
We are not seeing this issue after re-enabling DMD on my local build without applying any fix from bug 1051633 with following gaia/gecko:

https://git.quicinc.com/?p=b2g/mozilla/gecko.git;a=tag;h=refs/tags/AU_LINUX_GECKO_B2G_KK_2.0.01.04.00.114.085

https://git.quicinc.com/?p=b2g/mozilla/gaia.git;a=tag;h=refs/tags/AU_LINUX_GECKO_B2G_KK_2.0.01.04.00.114.085

It may be some other fix which has landed and solve this issue for us !. 

This bug can be closed if Cervantes is OK with this ! Thanks
Flags: needinfo?(ikumar)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.