Intermittent test_chaining.html | The played region should be continuous.http://mochi.test:8888/tests/content/media/test/variable-channel.ogg - got 0, expected 1

RESOLVED DUPLICATE of bug 1069289

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1069289
4 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: bechen)

Tracking

({intermittent-failure})

Trunk
ARM
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=45773190&tree=Mozilla-Inbound

Android 2.3 Emulator mozilla-inbound opt test mochitest-4 on 2014-08-12 11:17:44 PDT for push 813ad3e96004
slave: tst-linux64-spot-512

12:25:42     INFO -  181 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_chaining.html | The played region should be continuous.http://mochi.test:8888/tests/content/media/test/variable-channel.ogg - got 0, expected 1
12:25:42     INFO -  TEST-INFO | expected PASS
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

4 years ago
Assignee: nobody → bechen
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 42

4 years ago
(In reply to TBPL Robot from comment #41)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=48303793&tree=Mozilla-
> Inbound
> Android 2.3 Emulator mozilla-inbound opt test mochitest-5 on 2014-09-17
> 11:29:13
> revision: 29ba45e163d8
> slave: tst-linux64-spot-1208
> 
> 208 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_chaining.html
> | We should have received 2 metadataloaded event.
> http://mochi.test:8888/tests/content/media/test/variable-preskip.opus - got
> 1, expected 2
> 211 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_chaining.html
> | The played region should be
> continuous.http://mochi.test:8888/tests/content/media/test/variable-preskip.
> opus - got 0, expected 1

I can reproduce the dame failure on my desktop, but the reproduce rate is very low.
(In reply to Benjamin Chen [:bechen] from comment #42)
> I can reproduce the dame failure on my desktop, but the reproduce rate is
> very low.

|./mach mochitest-plain content/media/test/test_chaining.html --repeat 10000 --run-until-failure|
Run the comment above and wait for revelation to enlighten you.
(Assignee)

Comment 44

4 years ago
(In reply to JW Wang [:jwwang] from comment #43)
> (In reply to Benjamin Chen [:bechen] from comment #42)
> > I can reproduce the dame failure on my desktop, but the reproduce rate is
> > very low.
> 
> |./mach mochitest-plain content/media/test/test_chaining.html --repeat 10000
> --run-until-failure|
> Run the comment above and wait for revelation to enlighten you.

Yeah, I had used this command last night.

In fact, there are 2 failures inside.
1.
> 208 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_chaining.html
> | We should have received 2 metadataloaded event.
> http://mochi.test:8888/tests/content/media/test/variable-preskip.opus - got
> 1, expected 2
> 211 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_chaining.html
> | The played region should be
> continuous.http://mochi.test:8888/tests/content/media/test/variable-preskip.
> opus - got 0, expected 1

2.
> 164 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_chaining.html | The played region should > be continuous.http://mochi.test:8888/tests/content/media/test/variable-channel.ogg - got 0, expected 1

The first one looks like we are missing 1 metadataload event. It should be 2.
And the second one looks like we received metadataload event, but didn't play the element, or we play the element, but the play time is still 0.

Not sure what's the relationship between this 2 cases.
Do the 2 problems always show up together? If so, they might be 2 symptoms revealed by one cause.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Lets wait and see if bug 1069289 also fix the problem here.
Depends on: 1069289
Comment hidden (Treeherder Robot)
(Assignee)

Comment 75

3 years ago
No more failure after bug 1069289 is fixed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1069289
You need to log in before you can comment on or make changes to this bug.