Closed Bug 1052815 Opened 5 years ago Closed 5 years ago

[e10s] Closing toolbox in second tab disconnects the front from other toolbox

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(e10s+)

RESOLVED DUPLICATE of bug 1049103
Tracking Status
e10s + ---

People

(Reporter: miker, Assigned: miker)

References

(Blocks 1 open bug)

Details

STR:
1. Open two tabs.
2. Open a toolbox in each tab.
3. Close the second toolbox but leave the tab open.
4. Try to inspect something using the remaining toolbox.

None of the tools will work because the Front has somehow become disconnected or been destroyed.
The above STR need to be in an e10s instance of Fx.

As far as I can see this is what happens (I may very well be completely wrong):
1. When a tab is closed the onMessageManagerDisconnect observer is triggered.
2. mm.sendAsyncMessage("debug:disconnect"); is sent, which removes tab actors for all tabs.
3. The remaining toolbox is completely broken because there are no actors for it to interact with.

I have spent a few days debugging this and seem to be going in circles. I suspect that dcamp is the best person to look into this as he created this file.

@dcamp: Can you take a look at this? The more I look the more confused I get :o/
Flags: needinfo?(dcamp)
Can't find it now, but I think I've seen Alex mention this in another bug.
Flags: needinfo?(poirot.alex)
Yes, comment 1 is similar to what I described in bug 1049103 comment 3.
I described there what should be done.
Flags: needinfo?(poirot.alex)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049103
Flags: needinfo?(dcamp)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.