[B2G][Loop] Users are not switched to login screen after signing out of FxA while sitting on settings page

VERIFIED FIXED

Status

Firefox OS
Gaia::Loop
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Jordan de Geus(JordanD), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-exploratory][not blocking], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8471921 [details]
logcat_20140812_1515.txt

Description:
When the user suspends the app while viewing the Settings page, upon signing out of their Firefox Account within the device Settings and then the user returns to the Loop app, the user will see they are still logged into their account. If the user selects "Clean all Calls" or "Clean Shared links", upon logging back into a account, the user will observe the settings are retained.

Setup: 
- Install the Loop app on a device from: https://github.com/mozilla-b2g/firefoxos-loop-client

Repro Steps:
1) Update a Flame to 20140812000205
2) Launch app> Select Settings
3) Press Home button> Select Settings> Firefox Accounts> Logout
4) Return to Loop app and observe user still shows as signed in

Actual:
Loop app does not switch to login screen after signing out of FxA account

Expected:
Switching back to Loop app after signing out of FxA switches to login screen

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140812000205
Gaia: 1144cdc3a544f81c9bf71598aba1cb67d6c95a29
Gecko: 6495a7bd61ed
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 3/3
See attached: Logcat and video
http://youtu.be/7wG-c9Jut38
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.1 (319mb), Flame 2.0 (519mb), Buri 2.1, Buri 2.0

Actual: Users remain signed into their account upon switching back to the Loop app after signing out of their FxA 

Flame 2.1 (319mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140812040201
Gaia: e78e62125eb43c3a28cdc047987ba54430694a2f
Gecko: b53c2753ce9a
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0 (512mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140812000205
Gaia: 1144cdc3a544f81c9bf71598aba1cb67d6c95a29
Gecko: 6495a7bd61ed
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

--------------------------------------------------------

This issue does not occur on Flame 1.4(319mb), or Buri 1.4 as this feature was not available.

Flame 1.4 (319mb)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140812063005
Gaia: ec395d47cee9234ae93d2410d8ef8724dfc5d6cb
Gecko: 5b219153e2f4
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4 

Environmental Variables:
Device: Buri 1.4
BuildID: 20140812063005
Gaia: ec395d47cee9234ae93d2410d8ef8724dfc5d6cb
Gecko: 5b219153e2f4
Version: 30.0 (1.4)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Ideally, the user would be shown as logged out on loop as well. Odd any settings changed are still retained when the user logs back in. Since this only happens if the user remains on settings in loop not nominating to block on this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 3

3 years ago
Could you provide the Loop version. It looks like a regression.
(Reporter)

Comment 4

3 years ago
Loop Version: 609ec57

Updated

3 years ago
Whiteboard: [2.0-exploratory] → [2.0-exploratory][not blocking]

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Hi! I've tested this today with Loop master, and v2.0 flashed in my Flame and I can not reproduce. Could you confirm this? Thanks!
Flags: needinfo?(jdegeus)
(Reporter)

Comment 6

3 years ago
Hey Borja,
This issue does not occur on Flame v2.0(environmental variables below) running Loop version 2ee3206.

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140828000202
Gaia: ee5cf3aff7e66ec5e899bdffa27ef51bfa40f0f0
Gecko: 218771782328
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Flags: needinfo?(jdegeus) → needinfo?(borja.bugzilla)
Closing this after the confirmation of this is working as expected. Thanks Jordan!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(borja.bugzilla)
Resolution: --- → FIXED

Comment 8

3 years ago
Verified with Flame v2.0 kk and gecko-ef26d06.gaia-ddec117. Loop version: eb3a712
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.