Closed Bug 1053009 Opened 5 years ago Closed 3 years ago

[tablet] twitter.com in portrait mode doesn't adjust the content

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(platform-rel -)

RESOLVED WONTFIX
Tracking Status
platform-rel --- -

People

(Reporter: karlcow, Unassigned, Mentored)

References

()

Details

(Whiteboard: [mobile-compat-form] [country-all] [serversniff] [contactready] [tablet] [platform-rel-Twitter])

Site: https://twitter.com/mozilla
[tablet] twitter.com in portrait mode doesn't adjust the content

:: Steps To Reproduce

1. With a InFocus Firefox OS tablet
2. Go to https://twitter.com/mozilla
3. Put the device in portrait orientation


:: Expected Result

See the content scaled for the width of the viewport. An Android galaxy tab browser is receiving the mobile version of twitter.

:: Actual Result

The content is cropped out because it's too large for the window. I guess we are receiving a desktop version.

:: Additional Information

Software Version: 1.4
Device Information: InFocus
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
The Firefox OS user agent for tablet has the following pattern.
 Mozilla/5.0 (Tablet; rv:30.0) Gecko/30.0 Firefox/30.0

(version numbers are not relevant)
Mentor: kdubost
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → ARM
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-all] [serversniff] [contactready] [tablet]
it's not a "desktop version" - it just fails to reflow to take the new width into account. If you load it in portrait and rotate to landscape mode, you'll have too short lines.

I guess they listen to an orientationchange event on the window. Pending a decision in bug 920734, we don't support that - they'll have to do screen.addEventListener() and perhaps add moz-prefix to the event name. I'm not sure if things are prefixed or not.
Yep, it's prefixed. So something like:

screen.addEventListener("mozorientationchange", handleChange)
Whiteboard: [mobile-compat-form] [country-all] [serversniff] [contactready] [tablet] → [mobile-compat-form] [country-all] [serversniff] [contactready] [tablet] [platform-rel-Twitter]
platform-rel: --- → ?
Not tracking as platform-rel due to platform.

Please reopen if this report is still needed.
Status: NEW → RESOLVED
Closed: 3 years ago
platform-rel: ? → -
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.