libhost_stdc++compat.a(host_stdc++compat.o): build/mozilla/build/unix/stdc++compat/stdc++compat.cpp:147: _M_widen_init first defined here

RESOLVED FIXED in seamonkey2.31

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

unspecified
seamonkey2.31
x86
Linux

SeaMonkey Tracking Flags

(seamonkey2.31 fixed, seamonkey2.32 fixed, seamonkey2.33 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Building on comm-aurora for Linux Debug builds are red with the following
error:

libhost_stdc++compat.a
rm -f libhost_stdc++compat.a
/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/_virtualenv/bin/python /builds/slave/c-aurora-lnx-dbg/build/mozilla/config/expandlibs_exec.py --depend .deps/libstdc++compat.a.pp --target libstdc++compat.a --extract -- ar crs libstdc++compat.a stdc++compat.o 
/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/_virtualenv/bin/python /builds/slave/c-aurora-lnx-dbg/build/mozilla/config/expandlibs_exec.py --depend .deps/libhost_stdc++compat.a.pp --target libhost_stdc++compat.a --extract -- ar crs libhost_stdc++compat.a host_stdc++compat.o
../../../dist/bin/nsinstall -R -m 644 'libhost_stdc++compat.a' '../../../dist/host/lib'
libstdc++compat.a.desc
/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/_virtualenv/bin/python /builds/slave/c-aurora-lnx-dbg/build/mozilla/config/expandlibs_gen.py --depend .deps/libstdc++compat.a.desc.pp -o libstdc++compat.a.desc stdc++compat.o 
make[5]: Leaving directory `/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/build/unix/stdc++compat'
elfhack
make[5]: Entering directory `/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/build/unix/elfhack'
/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/_virtualenv/bin/python /builds/slave/c-aurora-lnx-dbg/build/mozilla/config/expandlibs_exec.py --depend .deps/elfhack.pp --target elfhack -- /tools/gcc-4.7.3-0moz1/bin/g++ -o elfhack -gdwarf-2 -std=gnu++0x -MD -MP -MF .deps/elfhack.pp -static-libstdc++ host_elf.o host_elfhack.o  ../../../build/unix/stdc++compat/libhost_stdc++compat.a
/usr/bin/ccache /tools/gcc-4.7.3-0moz1/bin/gcc -o dummy dummy.o -lpthread -static-libstdc++ -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id    -Wl,-rpath-link,/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/dist/bin -Wl,-rpath-link,/usr/local/lib 
Executing: /tools/gcc-4.7.3-0moz1/bin/g++ -o elfhack -gdwarf-2 -std=gnu++0x -MD -MP -MF .deps/elfhack.pp -static-libstdc++ host_elf.o host_elfhack.o ../stdc++compat/libhost_stdc++compat.a
/tools/gcc-4.7.3-0moz1/lib/gcc/i686-pc-linux-gnu/4.7.3/../../../libstdc++.a(ctype.o): In function `std::ctype<char>::_M_widen_init() const':
(.text._ZNKSt5ctypeIcE13_M_widen_initEv+0x0): multiple definition of `std::ctype<char>::_M_widen_init() const'
../stdc++compat/libhost_stdc++compat.a(host_stdc++compat.o):/builds/slave/c-aurora-lnx-dbg/build/mozilla/build/unix/stdc++compat/stdc++compat.cpp:147: first defined here
collect2: error: ld returned 1 exit status
make[5]: *** [elfhack] Error 1
make[5]: Leaving directory `/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla/build/unix/elfhack'
make[4]: *** [build/unix/elfhack/libs] Error 2
make[4]: Leaving directory `/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/builds/slave/c-aurora-lnx-dbg/build/objdir/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/builds/slave/c-aurora-lnx-dbg/build/objdir'
make: *** [build] Error 2

I'm going to make a guess that it has something to do with a mozconfig
entry.
(Assignee)

Updated

5 years ago
OS: Windows Vista → Linux
Summary: libhost_stdc++compat.a(host_stdc++compat.o): build/mozilla/build/unix/stdc++compat/stdc++compat.cpp:147: first defined here → libhost_stdc++compat.a(host_stdc++compat.o): build/mozilla/build/unix/stdc++compat/stdc++compat.cpp:147: _M_widen_init first defined here
(Assignee)

Comment 1

5 years ago
Created attachment 8482491 [details] [diff] [review]
remove the ldflags/host_ldflags from mozconfig. (v1)
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8482491 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 2

5 years ago
Comment on attachment 8482491 [details] [diff] [review]
remove the ldflags/host_ldflags from mozconfig. (v1)

Going for a post-push review.
(Assignee)

Comment 3

5 years ago
Comment on attachment 8482491 [details] [diff] [review]
remove the ldflags/host_ldflags from mozconfig. (v1)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined:  -debug doesn't build.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined:  -debug doesn't build. 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/1544be0a1732
Attachment #8482491 - Flags: approval-comm-beta?
Attachment #8482491 - Flags: approval-comm-aurora?
Attachment #8482491 - Flags: review?(bugspam.Callek)
Attachment #8482491 - Flags: review+
Attachment #8482491 - Flags: approval-comm-beta?
Attachment #8482491 - Flags: approval-comm-beta+
Attachment #8482491 - Flags: approval-comm-aurora?
Attachment #8482491 - Flags: approval-comm-aurora+
Note there may be a slight conflict with :IanN's sets of patches that touch the mozconfigs too, so CC'ing him here.

It would only be trivial bitrot though and I trust you both to resolve them appropriately
(Assignee)

Comment 5

5 years ago
Comment on attachment 8482491 [details] [diff] [review]
remove the ldflags/host_ldflags from mozconfig. (v1)

Pushed to comm-aurora:
https://hg.mozilla.org/releases/comm-aurora/rev/73a2ad9b6eb1
(Assignee)

Comment 6

4 years ago
Comment on attachment 8482491 [details] [diff] [review]
remove the ldflags/host_ldflags from mozconfig. (v1)

Pushed to comm-beta:
https://hg.mozilla.org/releases/comm-beta/rev/fa009516b937
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-seamonkey2.31: --- → fixed
status-seamonkey2.32: --- → fixed
status-seamonkey2.33: --- → fixed
Target Milestone: --- → seamonkey2.31
You need to log in before you can comment on or make changes to this bug.