[GFX-CLEANUP] Remove support for backbuffer from DrawingSurface

RESOLVED WONTFIX

Status

Core Graveyard
GFX
P4
normal
RESOLVED WONTFIX
19 years ago
9 years ago

People

(Reporter: Kevin McCluskey (gone), Assigned: Kevin McCluskey (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
Remove support for backbuffer from DrawingSurface.  Remove flags to blit from
backbuffer to front buffer. The backbuffer (i.e copyoffscreenbits) should not be
used anywhere in the XPCODE . If it is then it can be replaced by using an
existing RenderingContext.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10
(Assignee)

Comment 1

19 years ago
I have a fix for this in my tree. Will check in for M10
(Assignee)

Updated

19 years ago
Assignee: kmcclusk → ramiro
Status: ASSIGNED → NEW
(Assignee)

Comment 2

19 years ago
Fixed WIN32 Aug 20, 1999 4:11PM. Still needs to be removed from Gtk and Mac
implementations.

Ramiro, I'm reassigning to you to. After you remove from the Gtk implementation
of the RenderingContext reassign to Patrick (beard@netscape.com) to remove from
the Mac.

Updated

19 years ago
Assignee: ramiro → beard

Comment 3

19 years ago
Done on loonix, reassigning to beard.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
QA Contact: leger → kmcclusk

Comment 4

19 years ago
Updating QA Contact.  You guys will have to Verify this when done.  Thanks!

Updated

19 years ago
Target Milestone: M10 → M12

Comment 5

19 years ago
This will have to wait until we have a proper alternative.
(Assignee)

Comment 6

19 years ago
*** Bug 12330 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M12 → M13

Updated

18 years ago
Target Milestone: M13 → M15

Comment 7

18 years ago
Reassigning all compositor bugs to kevin.
Assignee: beard → kmcclusk
Status: ASSIGNED → NEW
Component: other → Compositor
QA Contact: kmcclusk → petersen
(Assignee)

Comment 8

18 years ago
Moving to M17.
Status: NEW → ASSIGNED
Target Milestone: M15 → M17
(Assignee)

Comment 9

18 years ago
Moving to M17.
(Assignee)

Comment 10

18 years ago
Moving to M18
Target Milestone: M17 → M18
(Assignee)

Comment 11

18 years ago
This bug is marked "future" because it is not critical for RTM (Release To 
Manufacturing). If anyone believes it is critical, please explain why in
this bug. 
Target Milestone: M18 → Future
(Assignee)

Comment 12

16 years ago
Build moving all existing future-P3 bugs to future-P4.
Priority: P3 → P4
<CTho|studying> roc: any idea if bug 10532 matters?
<roc> probably not
<roc> nuke it
<CTho|studying> "nuke" as in wontfix?
<roc> yeah
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 14

13 years ago
fyi, the original intent of this was that if you are blitting across differing
drawingsurfaces, you can't make assumptions about data organization, etc.

if you have a single drawingsurface with front and back buffers, you can make
all the assumptions you want and have maximum performance.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.