Closed Bug 1053204 Opened 6 years ago Closed 6 years ago

FileDescriptor::CloseCurrentProcessHandle() close invalid file descriptor

Categories

(Core :: Networking, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla34
blocking-b2g 2.0+
Tracking Status
firefox32 --- wontfix
firefox33 --- wontfix
firefox34 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1038461 +++

This bug is created based on Bug 1038461 Comment 82.

When an application started from homescreen, b2g process close invalid fd.
[Blocking Requested - why for this release]:

Nominate to "b2g-2.0+", because this bug blocks Bug 1038461.
blocking-b2g: --- → 2.0?
Get a call stack by uisng attachment 8472044 [details] [diff] [review], when an invalid fd is closed.
Assignee: nobody → sotaro.ikeda.g
I confirmed that RemoteOpenFileParent::OpenSendCloseDelete() always close fd twice.
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> I confirmed that RemoteOpenFileParent::OpenSendCloseDelete() always close fd
> twice.

Therefore second fd close becomes "invalid fd close" or "different fd close(fd is already reused case)".
Bug 1047149 might be related to this bug.
Component: General → Networking
Product: Firefox OS → Core
Comment on attachment 8472382 [details] [diff] [review]
patch - remove redundant close()

bent, can you review the patch soon? This bug blocks b2g-v2.0+ bug.
Attachment #8472382 - Flags: review?(bent.mozilla)
Priority: P1 → --
Comment on attachment 8472382 [details] [diff] [review]
patch - remove redundant close()

Review of attachment 8472382 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #8472382 - Flags: review?(bent.mozilla) → review+
Blocks a crash blocker -> blocking+.
blocking-b2g: 2.0? → 2.0+
hg repository and tryserver is closed now.
Tapas, can you include this in your test run?
Flags: needinfo?(tkundu)
(In reply to Sotaro Ikeda [:sotaro] from comment #10)
> hg repository and tryserver is closed now.

It seems to be tracked by Bug 1040308.
Gregor -- yes we are going to include this in the next run.
Flags: needinfo?(tkundu)
https://hg.mozilla.org/mozilla-central/rev/8f922378fab0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.