Closed Bug 1053245 Opened 6 years ago Closed 6 years ago

A string of numbers entered in the address bar prompts user with infobar asking if they'd like to go to the number

Categories

(Firefox :: General, defect)

x86
All
defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 34
Iteration:
34.2
Tracking Status
firefox33 --- verified
firefox34 --- verified

People

(Reporter: sevaan, Assigned: Gijs)

References

Details

Attachments

(1 file)

When entering any number into the address bar (no other characters or breaks), Firefox prompts the user with an infobar asking if they would like to go to that number: http://cl.ly/image/3e0Q2x0m3I0G

If the string of numbers is long, it breaks the browser's layout, cutting off the right-side of the window: http://cl.ly/image/2R2G3h3F1v3I

Problem affects both Mac and Windows (I have not tried it on Linux).
Flags: firefox-backlog+
Hrmpf. So these are all getting resolved as IP addresses. Try http://2130706433/ .

I think we should just stop supporting this without the appropriate prefixes and/or whitelisting to indicate you REALLY MEAN to be this clever. Or whatever the cool people call it when you do that thing. Stealing.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 34.2
Points: --- → 1
Marco, can you add this one? My other bugs are resolved or in review. Thanks!
Flags: needinfo?(mmucci)
Added to Iteration 34.2.  Can you mark the bug as [qa+] or [qa-] for verification.

(In reply to :Gijs Kruitbosch (intermittently here 14-15 August; then away until 19th) from comment #2)
> Marco, can you add this one? My other bugs are resolved or in review. Thanks!
QA Whiteboard: [qa?]
Flags: needinfo?(mmucci)
QA Whiteboard: [qa?] → [qa+]
The discussion and figuring out what we wanted was like 95% of the work here, AFAICT... anyway, here goes. Hope this matches what you were expecting. :-)
Attachment #8472428 - Flags: review?(jaws)
remote:   https://hg.mozilla.org/integration/fx-team/rev/90f6fca4674e
Flags: in-testsuite+
Whiteboard: [fixed-in-fx-team]
Gijs: So, what is the behavior we should be expecting, and testing?  Thanks!
Flags: needinfo?(gijskruitbosch+bugs)
QA Contact: alexandra.lucinet
(In reply to Liz Henry :lizzard from comment #6)
> Gijs: So, what is the behavior we should be expecting, and testing?  Thanks!

Putting in just numbers (from 0 to however much you'd like to type, see the screenshots in comment 0 - ok, perhaps that's a dangerous challenge, but for sure even really long numbers! ;-) ) in the location bar should load the search page, and not show a notification bar.


If you set a boolean whitelist pref in about:config for e.g. browser.fixup.domainwhitelist.7 to true then putting in just "7", it will open http://7/ (and show a server error page, because it won't be able to connect to a server at that address - that's expected).


Does that help? :-)
Flags: needinfo?(gijskruitbosch+bugs)
Gijs: Yes! Fabulous, thank you.
https://hg.mozilla.org/mozilla-central/rev/90f6fca4674e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
QA Contact: alexandra.lucinet → andrei.vaida
Reproduced the initial issue on the Nightly from 2014-08-13.

This is now verified fixed on Nightly 34.0a1 (2014-08-17) using Windows 7 64-bit, Ubuntu 14.04 LTS 32-bit and Mac OS X 10.9.4, according to the following behavior:
 - accessing a long string of numbers results in a search for that specific string
 - accessing a whitelisted string of long numbers (using the browser.fixup.domainwhitelist.* pref) results in a redirection to that URL (server error page), w/o the display of the infobar, as stated in Comment 7

Leaving the [qa+] keyword in place until the fix lands on Aurora.
Status: RESOLVED → VERIFIED
Comment on attachment 8472428 [details] [diff] [review]
ignore number-only hosts for our purposes,

Approval Request Comment
[Feature/regressing bug #]: 693808
[User impact if declined]: number-only hosts get interpreted as decimal IP addresses (which almost nobody uses) and produce puzzling notification bars ("Would you like to go to 42?")
[Describe test coverage new/current, TBPL]: has automated test coverage in this patch
[Risks and why]: low, small front-end change specific to this issue
[String/UUID change made/needed]: none
Attachment #8472428 - Flags: approval-mozilla-aurora?
Attachment #8472428 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Aurora 33.0a2 (2014-08-23) as well.
QA Whiteboard: [qa+] → [qa!]
Depends on: 1299391
You need to log in before you can comment on or make changes to this bug.