If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

M095 Trunk crash deleting mail accounts [@ nsMsgAccountManager::GetDefaultAccount]

VERIFIED DUPLICATE of bug 105670

Status

SeaMonkey
MailNews: Account Configuration
P1
critical
VERIFIED DUPLICATE of bug 105670
16 years ago
13 years ago

People

(Reporter: greer, Assigned: racham)

Tracking

({crash, topcrash})

Trunk
mozilla0.9.6
x86
Windows 98
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
Trunk and M095 users are reporting crashes when they try to delete profiles. 

(36663970)  - Windows 98  4.90 build 73010104   i made an e-mail account and
then tried to delete it
(36674599)  - Windows 98  4.10 build 67766446   tried to remove mail accounts 
created bevore i discovered the import utility
(
36674843)  - Windows 98  4.90 build 73010104   mozilla crashes second time when
i try to remove an account! seems this is broken in 0.9.5
(36674924)  - Windows 98  4.90 build 73010104   mozilla crashes EVERY time I try
to remove an e-mail account... i created this account just after I downloaded
the 0.9.5 and there was a mistake in the user name (by the way - it will be nice
if I can change the user name after the account is created -
(36677668)  - Windows 98  4.90 build 73010104   again and again - every time I
try to delete this account  Mozilla crashes. please  let me know if this can be
fixed before 0.9.

Several users do seem to crash with different steps:

 (36642517)  - Windows NT  5.0 build 2195        Mail/News module crashed after
clicking "Finish" in the account setup wizard. (A News account was created).
Subsequently  the Mail/News module crashes whenever started
(36653458)  - Windows NT  5.1 build 2600        Opening addressbook on windows
xp final ... for the first time.
(36653467)  - Windows 98  4.10 build 67766446  Account 488dff32 Attempting to
access Mozilla 9.5 mail which if and when it ever gets a spell checker will
probably become my default mail program to replace Messenger w/ Netscape 4.78
which is present default.
(36660564)  - Windows 98  4.10 build 67766446   Brought up 0.9.5 for the first
time (uninstalled 0.9.4 and then installed 0.9.5)  and went into "Mail & News"
for the first time (didn't have it installed with 0.9.4)  and it brought up the
empty window and then crashed.

Here's the stack:
         nsMsgAccountManager::GetDefaultAccount
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsMsgAccountManager.cpp  line 788]
         XPTC_InvokeByIndex    
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp 
line 154]
         XPCWrappedNative::CallMethod  
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp  line 1953]
         XPC_WN_GetterSetter   
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp 
line 1287]
         js_Invoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 811]
         js_InternalInvoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c 
line 902]
         js_GetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c  line 2434]
         js_Interpret   [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2570]
         js_Invoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 827]
         js_InternalInvoke      [d:\builds\seamonkey\mozilla\js\src\jsinterp.c 
line 902]
         JS_CallFunctionValue   [d:\builds\seamonkey\mozilla\js\src\jsapi.c 
line 3389]
         nsJSContext::CallEventHandler 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp  line 980]
         nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp  line 156]
         nsEventListenerManager::HandleEventSubType    
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp  line
1214]
         nsEventListenerManager::HandleEvent   
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp  line
1889]
         GlobalWindowImpl::HandleDOMEvent      
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp  line 624]
         DocumentViewerImpl::LoadComplete      
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp  line 1110]
         nsDocShell::EndPageLoad       
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp  line 3747]
         nsWebShell::EndPageLoad       
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp  line 918]
         nsDocShell::OnStateChange     
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp  line 3668]
         nsDocLoaderImpl::FireOnStateChange    
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 1110]
         nsDocLoaderImpl::doStopDocumentLoad   
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 749]
         nsDocLoaderImpl::DocLoaderIsEmpty     
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 647]
         nsDocLoaderImpl::DocLoaderIsEmpty     
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 650]
         nsDocLoaderImpl::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsDocLoader.cpp  line 578]
         nsLoadGroup::RemoveRequest    
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsLoadGroup.cpp  line 537]
         imgRequestProxy::OnStopRequest
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgRequestProxy.cpp  line 385]
         imgRequest::OnStopRequest     
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgRequest.cpp  line 681]
         ProxyListener::OnStopRequest  
[d:\builds\seamonkey\mozilla\modules\libpr0n\src\imgLoader.cpp  line 430]
         nsJARChannel::OnStopRequest   
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp  line 614]
         nsOnStopRequestEvent::HandleEvent     
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 177]
         PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c 
line 591]
         PL_ProcessPendingEvents       
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524]
         _md_EventReceiverProc 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash

Comment 1

16 years ago
reassigning to racham.
Assignee: sspitzer → racham
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 2

16 years ago
Reporter seems to be referring mail account as a profile. Changing the summary
from 'M095 Trunk crash deleting profiles' to 'M095 Trunk crash deleting mail
accounts' and changing the component to 'Account Manager'.

Esther, Ninoschka, could you reproduce this...? I can't reproduce this on my
Win2k box. thanks.
Status: NEW → ASSIGNED
Component: Profile Migration → Account Manager
Summary: M095 Trunk crash deleting profiles [@ nsMsgAccountManager::GetDefaultAccount] → M095 Trunk crash deleting mail accounts [@ nsMsgAccountManager::GetDefaultAccount]

Comment 3

16 years ago
105670 might be a dup of this with some more steps to reproduce. 

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 105670 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@ nsMsgAccountManager::GetDefaultAccount]
Crash Signature: [@ nsMsgAccountManager::GetDefaultAccount]
You need to log in before you can comment on or make changes to this bug.