History is destroyed upon leaving http://www.cnn.com/

VERIFIED DUPLICATE of bug 103978

Status

()

--
major
VERIFIED DUPLICATE of bug 103978
17 years ago
10 years ago

People

(Reporter: jrgmorrison, Assigned: radha)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
1) (optional) start with a clean, new profile
2) start the browser
3) Type http://www.mozilla.org/ in urlbar and hit enter
4) Check the listing under the Go menu item
5) Type http://www.cnn.com/ in urlbar and hit enter
6) Check the listing under the Go menu item
7) Type http://www.mozilla.org/newlayout in urlbar and hit enter
8) Check the listing under the Go menu item

Actual results: everything is fine until 7&8; after /newlayout is loaded, 
the history for that window has been erased. The Go menu shows only the current 
page in the list, and the back button is disabled

The key event here is _leaving_ http://www.cnn.com/. (The choice of the 
other two urls was just to have two very vanilla pages). The problem has 
something to do with the content on that CNN page (and presumably how it 
affects the firing of notifications). 

This worked in 9/21 win2k trunk, but is broken in 9/23 win2k trunk. I see that 
there was a checkin for session history in the period of time on the trunk.

  "Fix for bug 92824. Update index in session History only after onStartLoad
   notifications come for the page. r=adamlaock sr=rpotts" 

The cnn page does a lot of js 'document.write("<IFRAME...', sort of tricks. 
If you disable JS in Navigator, then this problem (unsurprisingly) goes away.

(NOTE: this is _not_ on the 0_9_4 branch!)
(Reporter)

Updated

17 years ago
Keywords: nsbranch
see also bug 103978

Comment 2

17 years ago
and bug 105299 - they're all the same bug i think
(Reporter)

Comment 3

17 years ago
Yes, this would appear to be bug 103978.

I'll let radha mark it as a dup. I just want to restate that the sequence
above is reproducible 100% in 9/23 and later builds, but not in a 9/21 trunk
build (on win2k). I think it is related to the checkin that happened 9/21
for session history (although perhaps this bug only became apparent due to
some later change in the CNN content).
(Reporter)

Comment 4

17 years ago
> and bug 105299 - they're all the same bug i think

That bug concerns the 'location.replace()' method. 

Note: in the content that is served by www.cnn.com to mozilla, there 
is _NO_ occurence of 'location.replace()' in any downloaded file.
(Reporter)

Comment 5

17 years ago
*&%*@# nsbranch?, nsbeta1? ... why are we (re)using such lame, generic keywords 
to track product targets. What's wrong with nsmachv? 
Keywords: nsbranch → nsbeta1
This is dupe of 103978. This bug is present in 0.9.5, but not in the trunk right 
now. However there are few more issues at cnn's site right now  due to expired 
pages and CSS initiated reload of a iframes. I'm working on them. Please see 
103978 for more info. 

*** This bug has been marked as a duplicate of 103978 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
v
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.