[e10s] Address bar is empty during page load if the tab was about:newtab, about:config (non-e10s?)

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Jan Melcher, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715214327

Steps to reproduce:

* Enable e10s
* Enter any search keyword or address into the adress bar and hit enter


Actual results:

The address bar is immediately emptied (leaving the placeholder text), until the page has been loaded or an error page is shown


Expected results:

The text in the adress bar should be unchanged until the page has been loaded.

Especiall when the loading takes a while, you lose track of what's loading in which tab. Even worse, you can't even stop and reload the page (hitting reload after stop simply does nothing, beause the address bar is empty).
tracking-e10s: --- → +

Comment 1

4 years ago
[bugday-20140818]

firefox-34.0a1.en-US.linux-x86_64 (17-Aug-2014) shows the keyword or address most of the time but in a few cases the address bar was rendered blank for a brief moment.
 OS: Ubuntu 14.04
 Hardware: x86_64

Comment 2

4 years ago
2014-08-18-03-02-05-mozilla-central-firefox-34.0a1.ru.linux-x86_64

Disappears for a moment while a page is loading in a new tab (about:newtab), but not in a non-new tab like home page.

Comment 3

4 years ago
[bugday-20140818]

On Windows 7, the same thing as is described in Comment 2 happens. It happens when the window is e10s but the tab is non e10s. E.g. about:newtab, about:config...

Updated

4 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Document Navigation
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
Summary: [e10s] Adress bar gets emptied during page load → [e10s] Address bar is empty during page load if the tab was about:newtab, about:config (non-e10s?)

Comment 4

4 years ago
Maybe it's similar to bug 983189?
Depends on: 1056443

Comment 5

2 years ago
-> tracy for testing
Flags: needinfo?(twalker)
This is WFM as follows:

1) In e10s browser, open a new tab (about:newtab). notice there is only background text "Search or enter address"
1a) or in e10s browser, open about:config. Notice "about:config" is sill in the address bar.
2) perform a search from the search bar.

Results:
The URL bar doesn't change, or go blank, until the search url is filled in. This is as expected.

Tested on 
Win 7, Nightly 47.0a1, 20160203030249
Mac 10.9.5, Nightly 47.0a1, 20160204030229
Ubuntu 14.04, Nightly 47.0a1, 20160204030229
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(twalker)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.