DTLS - error: 'SSL_REUSE_SERVER_ECDHE_KEY' was not declared in this scope --with-system-nss

RESOLVED FIXED in Firefox 33

Status

()

Core
WebRTC: Networking
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: karlt, Assigned: keeler)

Tracking

({regression})

unspecified
mozilla35
x86_64
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox33+ fixed, firefox34 fixed, firefox35 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
/mnt/ssd1/karl/moz/dev/media/mtransport/transportlayerdtls.cpp: In member function 'bool mozilla::TransportLayerDtls::Setup()':
/mnt/ssd1/karl/moz/dev/media/mtransport/transportlayerdtls.cpp:549:30: error: 'SSL_REUSE_SERVER_ECDHE_KEY' was not declared in this scope
In the directory  /mnt/sda11/karl/obj/media/mtransport/build
The following command failed to execute properly:
c++ -o transportlayerdtls.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /mnt/ssd1/karl/moz/dev/config/gcc_hidden.h -DLINUX -DUSE_INTERFACE_PRIORITIZER -DHAVE_STRDUP -DNR_SOCKET_IS_VOID_PTR -DR_DEFINED_INT2=int16_t -DR_DEFINED_UINT2=uint16_t -DR_DEFINED_INT4=int32_t -DR_DEFINED_UINT4=uint32_t -DR_DEFINED_INT8=int64_t -DR_DEFINED_UINT8=uint64_t -DMOZ_GLUE_IN_PROGRAM -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DSTATIC_EXPORTABLE_JS_API -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/mnt/ssd1/karl/moz/dev/media/mtransport/build -I. -I/mnt/ssd1/karl/moz/dev/media/webrtc/trunk/third_party/libjingle/source/ -I/mnt/ssd1/karl/moz/dev/media/mtransport/ -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/ -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nICEr/src/crypto -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nICEr/src/ice -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nICEr/src/net -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nICEr/src/stun -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nICEr/src/util -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/event -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/log -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/plugin -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/port/generic/include -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/registry -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/share -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/stats -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/util/libekr -I/mnt/ssd1/karl/moz/dev/media/mtransport/third_party/nrappkit/src/port/linux/include -I../../../dist/include -I/usr/include/nspr -I/usr/include/nss -I/usr/include -I/usr/include -I/usr/include -I/usr/include/pixman-1 -fPIC -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MP -MF .deps/transportlayerdtls.o.pp -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Werror=type-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DDEBUG -DTRACING -g -fno-omit-frame-pointer /mnt/ssd1/karl/moz/dev/media/mtransport/transportlayerdtls.cpp

Looks like the NSS version requirement needs a bump.

Updated

4 years ago
Summary: error: 'SSL_REUSE_SERVER_ECDHE_KEY' was not declared in this scope → DTLS - error: 'SSL_REUSE_SERVER_ECDHE_KEY' was not declared in this scope

Comment 1

4 years ago
Looks like some problem with using system NSS? Not sure what needs to be done there.
Flags: needinfo?(dkeeler)
I believe this line of configure.in needs to be updated:

3517: AM_PATH_NSS(3.16.1, [MOZ_NATIVE_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])

To say 3.17 instead of 3.16.1. I would have imagined this would have happened as part of bug 1049006, but it looks like it didn't.
Flags: needinfo?(dkeeler)
(Reporter)

Comment 3

4 years ago
Sorry, I should have been explicit about --with-system-nss.
Summary: DTLS - error: 'SSL_REUSE_SERVER_ECDHE_KEY' was not declared in this scope → DTLS - error: 'SSL_REUSE_SERVER_ECDHE_KEY' was not declared in this scope --with-system-nss
Created attachment 8476933 [details] [diff] [review]
patch
Assignee: nobody → dkeeler
Status: NEW → ASSIGNED
Attachment #8476933 - Flags: review?(mh+mozilla)
[Tracking Requested - why for this release]: Configurations that set --with-system-nss won't build.
status-firefox33: --- → affected
status-firefox34: --- → affected
tracking-firefox34: --- → ?
[Tracking Requested - why for this release]: see comment 5
tracking-firefox33: --- → ?
tracking-firefox34: ? → ---
Tracking to help our distro friends.
tracking-firefox33: ? → +
Comment on attachment 8476933 [details] [diff] [review]
patch

Review of attachment 8476933 [details] [diff] [review]:
-----------------------------------------------------------------

That won't work because AM_PATH_NSS doesn't handle versions of the form a.b well (iirc, there's a bug about that, but I can't find it now)
Attachment #8476933 - Flags: review?(mh+mozilla) → review-
Created attachment 8488312 [details] [diff] [review]
patch (now with 3.17.1)

Well, looks like we're using 3.17.1. now on 34/35 anyway, so this should work.
Attachment #8476933 - Attachment is obsolete: true
Attachment #8488312 - Flags: review?(mh+mozilla)
(Reporter)

Updated

4 years ago
Blocks: 1036737
Attachment #8488312 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/7812b7d5f6ee
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
David, could you please fill the uplift requests? Thanks
Flags: needinfo?(dkeeler)
Comment on attachment 8488312 [details] [diff] [review]
patch (now with 3.17.1)

Approval Request Comment
[Feature/regressing bug #]: bug 1049006 (basically, updating NSS without updating configure.in)
[User impact if declined]: users/distros will not be able to build with --with-system-nss
[Describe test coverage new/current, TBPL]: n/a
[Risks and why]: essentially none
[String/UUID change made/needed]: none
Attachment #8488312 - Flags: approval-mozilla-beta?
Attachment #8488312 - Flags: approval-mozilla-aurora?
Flags: needinfo?(dkeeler)
Attachment #8488312 - Flags: approval-mozilla-beta?
Attachment #8488312 - Flags: approval-mozilla-beta+
Attachment #8488312 - Flags: approval-mozilla-aurora?
Attachment #8488312 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/8f4c1a390eeb
https://hg.mozilla.org/releases/mozilla-beta/rev/0780dce35e25
status-firefox33: affected → fixed
status-firefox34: affected → fixed
status-firefox35: --- → fixed

Updated

3 years ago
Blocks: 1076983
You need to log in before you can comment on or make changes to this bug.