Set options.success automatically in sendChromeMessage()

RESOLVED DUPLICATE of bug 991582

Status

RESOLVED DUPLICATE of bug 991582
4 years ago
4 years ago

People

(Reporter: aknow, Assigned: aknow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8473459 [details] [diff] [review]
0001-set-options.success-automatically.patch

I am thinking of setting |options.success| automatically in sendChromeMessage() of ril_worker. That means we don't have to explicitly set it to true or false. The value always depends on whether the object contains an |errorMsg|. By this way --
1. All the messages without errorMsg are successful.
2. If the message is not successful, it guarantees that there is an |errorMsg| showing the details.
(Assignee)

Updated

4 years ago
Assignee: nobody → szchen
(Assignee)

Updated

4 years ago
Attachment #8473459 - Flags: feedback?(htsai)
Comment on attachment 8473459 [details] [diff] [review]
0001-set-options.success-automatically.patch

Review of attachment 8473459 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!
Attachment #8473459 - Flags: feedback?(htsai) → feedback+

Updated

4 years ago
See Also: → bug 991582
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 991582
You need to log in before you can comment on or make changes to this bug.