with junkbuster host name seems to resolve to old IP address

VERIFIED DUPLICATE of bug 38488

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 38488
17 years ago
16 years ago

People

(Reporter: Richard Herrell, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101201

While surfing with Junkbuster, I'll occasionally click on a link that takes me
to a new site. Sometimes, Mozilla will attempt to open the URL as if the host
name resolved to the same address as the previous page.

For example:

http://linuxtoday.com/news_story.php3?ltsn=2001-10-18-003-20-NW-CY

If I click on "Complete story ...", it tries to take me to:

http://lwn.net/2001/1018/

But it seems to be trying to take me to:

http://linuxtoday.com/2001/1018/

Which doesn't exist.  (Gives a 404 error)

I would blame junkbuster for resolving the host name incorrectly, but it never
occurs with Netscape 4.7


Reproducible: Sometimes
Steps to Reproduce:
1.Download junkbuster RPM for Red Hat Linux http://internet.junkbuster.com/
2.rpm -Uvh *junk*.rpm
2.5. /etc/rc.d/init.d/junkbuster start
3.Edit->Preferences->Advanced->Proxies
4. Manual 127.0.0.1 port 80005. Surf surf surf.


Actual Results:  See example in description.

Expected Results:  The host name resolves properly.

Keep up the great work.  Mozilla is displacing Netscape on my desktop rapidly,
and IE on my work desktop (if I could just get the plugins to install properly! )
Marking as dupe of bug 38488 ("junkbuster is broken - use http/1.0 to get
arround this"). 

Reporter: You can set http/1.0 in Edit -> Preferences -> Debug -> Networking.

*** This bug has been marked as a duplicate of 38488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.