Assertion failure: mHandleCreatedByOtherProcessWasUsed, at ../../../ipc/glue/FileDescriptor.cpp:69

RESOLVED DUPLICATE of bug 1054598

Status

RESOLVED DUPLICATE of bug 1054598
4 years ago
4 years ago

People

(Reporter: swu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Device: Flame
Gecko: c9f8cc9ce89c
Gaia: cd8c70eb624d1b0f56cbf56f52dcf3f6d24365ad

The issue happens on debug build with B2G_DEBUG=1

STR:
1. Install an app from Marketplace
2. Homescreen process crashed due to assertion failure
(Reporter)

Comment 1

4 years ago
Below are related logs.
PID 13415 is b2g process and PID 17059 is homescreen process.

08-15 17:49:57.162 I/Gecko   (13415): RemoteOpenFileParent: file '/data/local/webapps/{0a1df81b-fef2-4548-88ef-e0cd449e5c4b}/application.zip' was not found!

08-15 17:50:00.362 I/Gecko   (17059): IPDL protocol error: [PRemoteOpenFileChild] Received an invalid file descriptor!
08-15 17:50:00.372 F/MOZ_Assert(17059): Assertion failure: mHandleCreatedByOtherProcessWasUsed, at ../../../ipc/glue/FileDescriptor.cpp:69
(Reporter)

Comment 2

4 years ago
Backtrace:

Program received signal SIGSEGV, Segmentation fault.
0xb29bab3c in mozilla::ipc::FileDescriptor::CloseCurrentProcessHandle (this=0xbeba7070)
    at ../../../ipc/glue/FileDescriptor.cpp:68
68	  MOZ_ASSERT_IF(mHandleCreatedByOtherProcess,
(gdb) bt
#0  0xb29bab3c in mozilla::ipc::FileDescriptor::CloseCurrentProcessHandle (this=0xbeba7070)
    at ../../../ipc/glue/FileDescriptor.cpp:68
#1  0xb25f499a in mozilla::ipc::FileDescriptor::~FileDescriptor (this=0xbeba7070, __in_chrg=<optimized out>)
    at ../../dist/include/mozilla/ipc/FileDescriptor.h:77
#2  0xb2bac23a in mozilla::net::PRemoteOpenFileChild::OnMessageReceived (this=0xad964330, __msg=...)
    at PRemoteOpenFileChild.cpp:171
#3  0xb2a5c50a in mozilla::dom::PContentChild::OnMessageReceived (this=0xb1751818, __msg=...)
    at PContentChild.cpp:3964
#4  0xb29bed9e in mozilla::ipc::MessageChannel::DispatchAsyncMessage (this=0xb1751848, aMsg=...)
    at ../../../ipc/glue/MessageChannel.cpp:1222
#5  0xb29be88a in mozilla::ipc::MessageChannel::DispatchMessage (this=0xb1751848, aMsg=...)
    at ../../../ipc/glue/MessageChannel.cpp:1104
#6  0xb29be7d0 in mozilla::ipc::MessageChannel::OnMaybeDequeueOne (this=0xb1751848)
    at ../../../ipc/glue/MessageChannel.cpp:1087
#7  0xb25ce19c in DispatchToMethod<FdWatcher, void (FdWatcher::*)()> (obj=0xb1751848, method=
    (void (FdWatcher::*)(FdWatcher * const)) 0xb29be679 <mozilla::ipc::MessageChannel::OnMaybeDequeueOne()>, arg=...) at ../../../ipc/chromium/src/base/tuple.h:383
#8  0xb25ce110 in RunnableMethod<FdWatcher, void (FdWatcher::*)(), Tuple0>::Run (this=0xb173eb20)
    at ../../../ipc/chromium/src/base/task.h:307
#9  0xb29b2304 in mozilla::ipc::MessageChannel::RefCountedTask::Run (this=0xb173f178)
    at ../../dist/include/mozilla/ipc/MessageChannel.h:397
#10 0xb29b24ac in mozilla::ipc::MessageChannel::DequeueTask::Run (this=0xab2dd960)
    at ../../dist/include/mozilla/ipc/MessageChannel.h:414
#11 0xb299316c in MessageLoop::RunTask (this=0xbeba7da4, task=0xab2dd960)
    at ../../../ipc/chromium/src/base/message_loop.cc:357
#12 0xb29931c8 in MessageLoop::DeferOrRunPendingTask (this=0xbeba7da4, pending_task=...)
    at ../../../ipc/chromium/src/base/message_loop.cc:365
#13 0xb29934fc in MessageLoop::DoWork (this=0xbeba7da4)
    at ../../../ipc/chromium/src/base/message_loop.cc:443
#14 0xb29c1a0e in mozilla::ipc::DoWorkRunnable::Run (this=0xb173e920)
    at ../../../ipc/glue/MessagePump.cpp:233
#15 0xb2626d96 in nsThread::ProcessNextEvent (this=0xb174a230, aMayWait=false, aResult=0xbeba7bf7)
    at ../../../xpcom/threads/nsThread.cpp:770
#16 0xb2650056 in NS_ProcessNextEvent (aThread=0xb174a230, aMayWait=false)
    at /home/sywu/work/mozilla-central/xpcom/glue/nsThreadUtils.cpp:265
#17 0xb29c1404 in mozilla::ipc::MessagePump::Run (this=0xb1701c40, aDelegate=0xbeba7da4)
    at ../../../ipc/glue/MessagePump.cpp:99
#18 0xb29c1ce2 in mozilla::ipc::MessagePumpForChildProcess::Run (this=0xb1701c40, aDelegate=0xbeba7da4)
    at ../../../ipc/glue/MessagePump.cpp:302
#19 0xb2992da4 in MessageLoop::RunInternal (this=0xbeba7da4)
    at ../../../ipc/chromium/src/base/message_loop.cc:229
#20 0xb2992d3e in MessageLoop::RunHandler (this=0xbeba7da4)
    at ../../../ipc/chromium/src/base/message_loop.cc:222
#21 0xb2992d1e in MessageLoop::Run (this=0xbeba7da4) at ../../../ipc/chromium/src/base/message_loop.cc:196
#22 0xb3d0b544 in nsBaseAppShell::Run (this=0xb0bc6700) at ../../../widget/xpwidgets/nsBaseAppShell.cpp:164
#23 0xb4a25e38 in XRE_RunAppShell () at ../../../toolkit/xre/nsEmbedFunctions.cpp:702
#24 0xb29c1b94 in mozilla::ipc::MessagePumpForChildProcess::Run (this=0xb1701c40, aDelegate=0xbeba7da4)
    at ../../../ipc/glue/MessagePump.cpp:272
#25 0xb2992da4 in MessageLoop::RunInternal (this=0xbeba7da4)
    at ../../../ipc/chromium/src/base/message_loop.cc:229
#26 0xb2992d3e in MessageLoop::RunHandler (this=0xbeba7da4)
    at ../../../ipc/chromium/src/base/message_loop.cc:222
#27 0xb2992d1e in MessageLoop::Run (this=0xbeba7da4) at ../../../ipc/chromium/src/base/message_loop.cc:196
#28 0xb4a258b2 in XRE_InitChildProcess (aArgc=5, aArgv=0xbeba8904)
    at ../../../toolkit/xre/nsEmbedFunctions.cpp:539
#29 0x0000962c in content_process_main (argc=7, argv=0xbeba8904)
    at ../../../ipc/app/../contentproc/plugin-container.cpp:148
#30 0x000096ca in main (argc=8, argv=0xbeba8904) at ../../../ipc/app/MozillaRuntimeMain.cpp:11
(Reporter)

Comment 3

4 years ago
Mark a duplicate as another same bug already under dicussion.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1054598
You need to log in before you can comment on or make changes to this bug.