email notification only occur when the screen is on

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: hub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I only get the email notifications when my screen is turned on. Which mean that I don't get notification, unless the poor "on" button design of the flame make it switch on in my pocket.
Hub, fellow FxOS hacker, please provide more information when filing bugs.  This could be any number of things happening:
- We don't have a data connection when the screen is off so we aren't actually syncing when the screen is off.
- The alarm sounds aren't happening until the screen turns on.  I think I've seen a bug go by on that somewhere, but I can't find it for the life of me.

What would be most useful right now is for you to describe the network situation for your device, what actual version of FxOS you are running, and which of the above situations it seems like is happening.

Assuming it's not the system notifications bug, the next useful thing is to provide a logcat as described at https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo, although in some cases the answer is just "no network, no sync" and we dupe to bug 907028 or one of its friends.
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Comment 2

4 years ago
I can't really describe the network situation beside that it has
1. wifi on (I'm at home most of the time)
2. cell data (this is my daily rider) - in case wifi is off or I am out of the house.

Anything else is opaque to me. My Android phone in the same situation do provide notification of incoming emails (and not only, but this is the topic of that bug).

This phone doesn't even have ADB enabled: this is not a development phone, so no logcat.
(Reporter)

Comment 3

4 years ago
Could be effectively bug 907028, but then it is completely cryptic in its title.

What I expect is that the phone tell me I'm getting emails when the phone is in my pocket. Otherwise there is no point.
(In reply to Hubert Figuiere [:hub] from comment #3)
> What I expect is that the phone tell me I'm getting emails when the phone is
> in my pocket. Otherwise there is no point.

Absolutely agreed.  But we need to figure out what is going wrong and how/why in your case.

(In reply to Hubert Figuiere [:hub] from comment #2)
> This phone doesn't even have ADB enabled: this is not a development phone,
> so no logcat.

I'm pretty sure you can turn adb on on any FxOS device, but I get the situation where you may not always have a computer available to grab a logcat (or may not want to).

However, could you please let us know what version of Firefox OS your device is using and how recent the build is?  If you're not on at least a very recent v2.0 build (last few days), you'll want to update.


Also, the root question still stands.  Do you turn the phone on and it goes "bing bing bing bing bing" immediately, or just you turn the screen on and and then like maybe after a minute or two it goes "bing bing bing".  Also important to know is what value you have set the periodic sync interval to for all of your accounts.
Flags: needinfo?(hub)
Some background: (eek midair, so may dupe some asuth comments):

There are some email-specific notification overrides in the system app:

https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/notifications.js

Searching for "email" will show them, but basically, the screen will not turn on for them, there was a recent change about vibration. The original UX motivation was to not disturb the user during the night-time when sleeping of unwanted effects like flashing the screen on. The full behaviors may need tweaking though.

What would be interesting to know is:

1) If you have the notifications in the notification tray, just that you were not audibly or visibly notified. If so, then this is about notification behavior overrides of the system app. (Long term, I want more general app control of behaviors instead of specific system overrides, filed bug 912645 to track that)

2) Or if there are no email notifications in the notification tray, but on opening the app and syncing you get messages that should have been found during periodic sync. Then probably one of the network-related bugs.
(Reporter)

Comment 6

4 years ago
It is 2.0 with whatever OTA ships. 20140811160205 for the buildID and 1144cdc3 for the gaia commit (2014-08-11 17:48:27)

And to be clear, I don't want the screen to turn on. This is one of these Android stupidities I dislike. But I actually want the notification sound/vibration.

1. Not sure when the notification appears because I don't see the screen before that. But when I switch on they are here. They can either already be here or appear so fast.... (dot in the top bar)

2. I get the notification when I switch the screen on: I'm in the lock screen, I have to put my lock PIN, etc. So definitely this happen in the background.
Flags: needinfo?(hub)
(Reporter)

Comment 7

4 years ago
The notification date isn't "now". Not sure if this is the date at which the notification is posted or the date of the email. But in the former case that mean we just miss the "vibrate" or sound until on switch the screen on.

Comment 8

9 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.