[UX] Define experience for "report broken site"

RESOLVED DUPLICATE of bug 1240064

Status

()

Toolkit
Safe Browsing
RESOLVED DUPLICATE of bug 1240064
3 years ago
2 years ago

People

(Reporter: mmc, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ux])

Attachments

(1 attachment)

This may end up in the purview of Cloud Services. I envision a form similar to https://www.google.com/safebrowsing/report_phish/
Blocks: 1029886
After discussion with Bill, this should be hosted by us with the initial purpose of accepting feedback in an organized fashion.
Duplicate of this bug: 1083105
Blocks: 1083105

Updated

3 years ago
Points: --- → 3
Flags: qe-verify-
Flags: firefox-backlog+
Whiteboard: [ux]

Comment 3

3 years ago
(In reply to [:mmc] Monica Chew (please use needinfo) from comment #1)
> After discussion with Bill, this should be hosted by us with the initial
> purpose of accepting feedback in an organized fashion.

Hi Monica/Javaun

Can you help us understand the common use case for this kind of feedback?  When do we want/expect users to report back to us and what would they be reporting?  What kind of breakage are we expecting to hear about?
Flags: needinfo?(mmc)
Flags: needinfo?(jmoradi)
The point of this feedback is to vet the blocklist and make sure we aren't breaking high-volume sites for lots of users, and also helps us make decisions about what kind of allowlisting we need to support in the future. The current allowlist just disables tracking protection on the entire site, but power users may want more or different options.

I chatted about this with psackl a while back and we came to the conclusion that it would be better to bundle reporting with "Disable protection for this site", since that's the clearest indication we have that users are dissatisfied. This would work similar to SSL reporting where the user can opt-in to sending the error (in our case, we'd need the top-level URL in addition to resources being blocked) just once or every time they click "Disable protection".
Flags: needinfo?(mmc)
Created attachment 8553938 [details]
Screen Shot 2015-01-23 at 1.06.29 PM.png

Here's the SSL reporting form.
Monica says it very well. In addition to improving our tool, simply offering users this contextual option is a better experience, as it demonstrates Mozilla can easily accept their feedback.
Flags: needinfo?(jmoradi)
Component: DOM: Security → Safe Browsing
Product: Core → Toolkit
Blocks: 1055176
No longer blocks: 1083105
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1240064
You need to log in before you can comment on or make changes to this bug.