Closed Bug 1054416 Opened 8 years ago Closed 8 years ago

[B2G][2.0][l10n][Settings][Internet Sharing] Japanese: The string "Wi-Fi hotspot" is truncated.

Categories

(Mozilla Localizations :: ja / Japanese, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: psiphantong, Assigned: marsf)

References

Details

(Whiteboard: [2.0-exploratory] [l10n])

Attachments

(1 file)

Attached image 2014-08-15-14-04-05.png
Description:
The string "Wi-Fi hotspot" is truncated under Settings > Internet Sharing.

Repro Steps:
1) Update a Flame to BuildID: 20140815000200.
2) Set the device language as Japanese.
3) Navigate to Settings > Internet Sharing.


Actual:
The "Wi-Fi hotspot" string is truncated in Japanese.

Expected:
The "Wi-Fi hotspot" string is NOT truncated in Japanese.

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140815000200
Gaia: 295c7f50707372e5af6d8e83148d2d970076dfd6
Gecko: 879c5208084f
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro Frequency: 100%
See attached screenshot
This issue also reproduces on the Flame 1.4 (319mb) as the The "Wi-Fi hotspot" string is truncated.

Flame 1.4 (319mb)

Environmental Variables:
Device: Flame 1.4
BuildID: 20140815063005
Gaia: ab9a57d204c8c06cccc70cb7190da789fe17a3cb
Gecko: 3da3115ee33b
Version: 30.0 (1.4)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Summary: [B2G][2.0][l10n][Settings][Find My Device] Japanese: The string "Wi-Fi hotspot" is truncated. → [B2G][2.0][l10n][Settings][Internet Sharing] Japanese: The string "Wi-Fi hotspot" is truncated.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
In Japan, The word "ホットスポット" (hotspot) is registered trademark of NTT Communications since 2002.
Therefore we use "アクセスポイント" (access point) instead of using "ホットスポット" and we cannot shorten.

In other side, NTT Com. may not restrict to use the word that is not used for commercial service.
http://www.itmedia.co.jp/broadband/0204/30/top10.html

dynamis:
How do you think about it?
Flags: needinfo?(bugzilla)
My suggestion is: "Wi-Fi テザリング" (Wi-Fi Tethering)
This is shorter and used in some Japanese devices.
"USB テザリング" is also used in the page and good to keep consistent terms.
Flags: needinfo?(bugzilla)
one more reason we can use "Wi-Fi テザリング":

KDDI use it:
http://www.au.kddi.com/mobile/service/smartphone/tethering/type/
Assignee: nobody → chimantaea_mirabilis
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.