uplift about:home/about:newtab search suggestions to Firefox 33

VERIFIED FIXED in Firefox 33

Status

()

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Gavin, Assigned: adw)

Tracking

29 Branch
Firefox 33
Points:
5
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox33 verified, firefox34 verified)

Details

Bug 612453, bug 1028985, bug 1006103, bug 1007979, bug 1048198 and possibly others need to hit 33. I think all of the important regressions have been sorted out, reviewing the dependency trees.
Flags: firefox-backlog+
(Assignee)

Comment 1

4 years ago
Do we want to fix bug 1047354 first?  I know Matt thinks we should -- bug 612453 comment 90 and previous.
Tough call - not sure how much work that will be.
Yes, the current behavior is confusing.
Bug 1047354 is now finished except for a minor nit for the mockup.
I filed bug 1054951 to break down the implementation.

The design suggests only one string change (the addition of »History« next to the suggestions from history). If that would be the dealbreaker for uplifting, I'd be happy to leave it out for 33 (and ship it with 34 or 35).

Updated

4 years ago
Points: --- → 5
Flags: qe-verify+

Updated

4 years ago
Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 34.3
OK, we're going to uplift what we have now and try to get bug 1054951 as well, but not block on it.
QA Contact: cornel.ionce
(Assignee)

Comment 5

4 years ago
We'll need the following, and I'll request approval in each:

* Bug 612453 - Provide search suggestions on Firefox Start Page (about:home)
* Bug 1007979 - refactor nsSearchSuggestions to use a reusable JSM
* Bug 1048198 - SearchBar Search Suggestion is no longer able to disable (regression from 1007979)
* Bug 1041534 - Refactor search tests to remove some code duplication
* Bug 1028985 - Provide search suggestions on Firefox new tab page (about:newtab)

We need bug 1006103 too, but it landed on 33.

There's the nice Ctrl-K handling in bug 1041678 and its follow-ups, but I think we should let them ride the train.

With all the above applied, relevant tests pass locally for me, and the feature works in brief manual testing.  https://tbpl.mozilla.org/?tree=Try&rev=fba51f37ff40
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox33: --- → fixed
status-firefox34: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Gavin, do you see a way to implement bug 1054951 (visual consolidation) and uplift it before 33 hits release?
Flags: needinfo?(gavin.sharp)
We may be able to uplift it, but it's hard to say before we've broken it down. We should try.
Flags: needinfo?(gavin.sharp)
Assigning to Petruta since this is her feature.
QA Contact: cornel.ionce → petruta.rasa
Marking as verified based on verification of bugs mentioned in comment 0 and comment 5.
Status: RESOLVED → VERIFIED
status-firefox33: fixed → verified
status-firefox34: fixed → verified
You need to log in before you can comment on or make changes to this bug.