[B2G][Email] Signature text field is not scrollable when editing text field

VERIFIED DUPLICATE of bug 1052951

Status

Firefox OS
Gaia::E-Mail
P3
normal
VERIFIED DUPLICATE of bug 1052951
4 years ago
3 years ago

People

(Reporter: Josh Schmitt [Joshs], Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected)

Details

(URL)

(Reporter)

Description

4 years ago
Description:
User is unable to scroll in the Signature text field.

Repro Steps:
1) Update a Flame to 20140815040204
2) Connect to a Data/Wifi network
3) Launch the Email app
4) Sign into a valid Email address
5) Go into the settings of the Email
6) Edit the 'Signature' of the Email
7) Type a few words to make the text go off screen

Actual:
User cannot scroll the text to edit different words off screen.

Expected:
The text is scrollable or auto wraps so the user can edit text with no issues.

Environmental Variables:
Device: Flame Master
Build ID: 20140815040204
Gaia: 9979fccc6321be72cd17370f3a20c65bc376af33
Gecko: c9f8cc9ce89c
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
Repro frequency: 100%
See attached: https://www.youtube.com/watch?v=J-kK23jK_-Q
(Reporter)

Comment 1

4 years ago
Issue does not occur on 2.0 Flame.

Signature feature does not exist in 2.0

Environmental Variables:
Device: Flame 2.0 319MB & 512MB
Build ID: 20140812000205
Gaia: 1144cdc3a544f81c9bf71598aba1cb67d6c95a29
Gecko: 6495a7bd61ed
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(pbylenga)
This is a new feature to email, need info on Edward as the qa lead owner of Email for 2.1 work for nomination triage.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(edchen)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 3

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Flags: needinfo?(edchen)
Priority: -- → P3
QA Contact: edchen
triage: 2.1+

I can get it to scroll sometimes but it's not consistent and it's very frustrating. This makes a long single-line sig almost impossible to edit.
blocking-b2g: 2.1? → 2.1+

Comment 5

3 years ago
Auto wrap the signature can be much easier in this case.
Update spec to bug 1052951.
Duping to bug 1052951 since Juwei updated the design doc on that ticket to include fixing this, and that ticket will have the pull request with the code change.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1052951

Comment 7

3 years ago
[Environment]
Gaia      fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/fb5e796da813
BuildID   20140902160204
Version   34.0a2
ro.build.version.incremental=eng.cltbld.20140820.195518
ro.build.date=Wed Aug 20 19:55:28 EDT 2014


[Result]
PASS
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+] [COM=Gaia::E-Mail]
You need to log in before you can comment on or make changes to this bug.