install.rdf generator needs support for targetPlatform in package.json

RESOLVED WONTFIX

Status

Add-on SDK
General
P2
enhancement
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: TGOS, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Now that the SDK has support for "unpack" in "package.json", it is also possible to bundle native libraries with SDK add-ons and use them via "ctypes.js". This is an important feature for porting some older add-ons with native libraries to the new SDK, since the SDK is definitely the future of add-on development and offers a lot of neat features for developers. However the problem is that libraries are platform specific and thus the add-on may not run on all platforms. "install.rdf" offers "<em:targetPlatform>" for exactly this purpose but as far as I can see, the SDK has no support for it.

IMHO "targetPlatform" (or maybe "targetPlatforms", plural) should be an array of strings within package.json to support multiple platforms and each entry should generate one "targetPlatform" tag in the generated "install.rdf".

Updated

4 years ago
Priority: -- → P2
cfx.py will no longer be updated, jpm is the replacement, and the plan there is to avoid the need to generate an install.rdf which will resolve this issue.
Blocks: 840023
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.