Closed Bug 1055026 Opened 5 years ago Closed 5 years ago

Add French Canadian keyboard

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86_64
Linux
defect
Not set

Tracking

(relnote-b2g ?)

RESOLVED FIXED
Tracking Status
relnote-b2g --- ?

People

(Reporter: hub, Assigned: hub)

References

Details

Attachments

(1 file)

Add French Canadian keyboard.

Because: 

1. French Canadian
2. Bug 1049514 and bug 1046036 - I use fr-CA layout as a workaround on Android. No need on iOS.

Note: this is just a keyboard layout. Autocompletion is French.
Assignee: nobody → hub
Attachment #8474585 - Flags: review?(rlu)
Comment on attachment 8474585 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22997

This seems to be based on an old version of English layout, please help rebase to see the latest update.
Specifically, if you need to define "alternateLayout" section, it has to define a special structure for ',' key, see
https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/layouts/en.js#L70

But, maybe for fr-CA, we don't have to define alternateLayout, so that it could reuse the default one. In general, we would need to customize this if you need localized currency symbol.
Attachment #8474585 - Flags: review?(rlu)
(In reply to Hubert Figuiere [:hub] from comment #0)
> Add French Canadian keyboard.
> 
> Because: 
> 
> 1. French Canadian
> 2. Bug 1049514 and bug 1046036 - I use fr-CA layout as a workaround on
> Android. No need on iOS.

BTW, Hubert, could you please elaborate why it's no need on iOS?
It won't auto-correct the word in French even when you're using English layout?

Thanks.

> 
> Note: this is just a keyboard layout. Autocompletion is French.
(In reply to Rudy Lu [:rudyl] from comment #3)
> (In reply to Hubert Figuiere [:hub] from comment #0)
> > Add French Canadian keyboard.
> > 
> > Because: 
> > 
> > 1. French Canadian
> > 2. Bug 1049514 and bug 1046036 - I use fr-CA layout as a workaround on
> > Android. No need on iOS.
> 
> BTW, Hubert, could you please elaborate why it's no need on iOS?

See bug 1049514 and bug 1046036 that describe what the problem is.

> It won't auto-correct the word in French even when you're using English
> layout?

iOS will. I can switch language WITHOUT switching layout at least using a locale. Language != layout. At least you can dissociate it.

The only reason I care about the "fr-CA" layout it is because it is much like the "en" layout - but I can have autocompletion in French. It seems to be, for me an easier fix.

I doubt our BD or partners care about the French Canadian market otherwise.
(In reply to Rudy Lu [:rudyl] from comment #2)
> Comment on attachment 8474585 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22997
> 
> This seems to be based on an old version of English layout, please help
> rebase to see the latest update.

It is based on 
commit 35a279f09c0a074b30bd5ac398081b5e5691256b
Date:   Fri Aug 1 08:07:06 2014 +0530

Let's see if I missed anything in a week.
> The only reason I care about the "fr-CA" layout it is because it is much
> like the "en" layout - but I can have autocompletion in French. It seems to
> be, for me an easier fix.
> 
> I doubt our BD or partners care about the French Canadian market otherwise.

Just to be clear. This solve only the case of "I want to type French with the keyboard I type English with".
Comment on attachment 8474585 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22997

Rebase the PR to tonights code. Copied from the new en.js layout.
Attachment #8474585 - Flags: review?(rlu)
Status: NEW → ASSIGNED
Comment on attachment 8474585 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/22997

Looks good to me.
Thank you.
Attachment #8474585 - Flags: review?(rlu) → review+
Merged
https://github.com/mozilla-b2g/gaia/commit/253e0991563e9dcd44b55da315bb3f0a2ce8ac94
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Release Note Request (optional, but appreciated)
[Why is this notable]:
[Suggested wording]:
[Links (documentation, blog post, etc)]:
relnote-b2g: --- → ?
I forgot the comment:
"Added French Canadian to the available keyboard layouts".

This is of course conditional to having the layout built in.
You need to log in before you can comment on or make changes to this bug.