It's not really worth renaming this I think. Let's embrace the web.
Attachment #8475203 - Flags: review?(bugs)
Comment on attachment 8475203 [details] [diff] [review] named.patch The new name should be NamedNodeMap, not NamedAttrMap.
Attachment #8475203 - Flags: review?(bugs) → review-
https://tbpl.mozilla.org/?tree=Try&rev=e2c0780e8214 This patch keeps nsIDOMMozNamedAttrMap but without any methods and attributes just to be compatible with existing addons. I marked this interface builtinclass.
Name NamedNodeMap of course doesn't make any sense, but since DOM 3 Core had that (for Nodes, not only for Attrs), I guess this is fine.
Comment on attachment 8475275 [details] [diff] [review] named.patch Since we have even internal usage for the .idl interface, I wouldn't remove it. The casting is ugly and error prone. Why not just rename the webidl interface?
Attachment #8475275 - Flags: review?(bugs) → review-
https://tbpl.mozilla.org/?tree=Try&rev=ab4d8237fbd3 Ok, I just tried to remove a idl interface with this patch. But it can be done in a different patch.
Comment on attachment 8476607 [details] [diff] [review] named.patch >-/** >- * This is a temporary, non-standard interface, to ease the transition to a >- * world where Attr no longer inherits from Node. >- */ >- I don't see reason for this change.
Attachment #8476607 - Flags: review?(bugs) → review+
Assignee: nobody → amarchesini
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.