If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View-Source improperly caching output from CGI's

RESOLVED DUPLICATE of bug 55583

Status

()

Core
Document Navigation
--
major
RESOLVED DUPLICATE of bug 55583
16 years ago
15 years ago

People

(Reporter: Nathan Humble, Assigned: bz)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
View-source seems to be caching the source from CGI scripts and not updating
it even though the rendered page updates.  I am not having a problem with the
POST data being sent, I am having a problem with the source being from an old
version of the page.  This is a major problem when developing CGI's and
previewing the output in Mozilla (especially when hidden fields are involved).

Comment 1

16 years ago
.
Assignee: asa → bzbarsky
Component: Browser-General → Networking
Whiteboard: DUPEME
Yup.  This is the same problem as the form data being resent actually.  We need
to change the way we pull source from the cache....

This will hopefully get fixed soon, since it requires interface changes and
seems like a major 1.0 stopper to me.  :(

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 3

15 years ago
->docshell per other bug.
Component: Networking → Embedding: Docshell
You need to log in before you can comment on or make changes to this bug.