Closed Bug 1055889 Opened 8 years ago Closed 8 years ago

Awesome bar doesn't update when a site is hovered over in the autocomplete drop-down

Categories

(Firefox :: Address Bar, defect)

31 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1043584

People

(Reporter: mathew.hodson, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715214327

Steps to reproduce:

1. Type in a letter so that something comes up in the URL. For example, the letter "t" or whatever works for you. It has to produce more than one result in the awesome bar. For example "twitter.com" is autocompleted in the location bar, and twitch.tv is the first result in the drop-down.

2. Now take your mouse pointer and hover over the first site in the dwrop-down. This would be the top-most item in the pull down menu or just underneath the location bar.

3. Do not click there! Just mouse over so that this new URL is highlighted.

4. Now move the mouse back to the location bar and click there. This will close the drop-down menu showing the other results which were called upon when you typed in "t" or whatever you happened to type.

5. Now you should see is the URL that was autocompleted when you typed in "t" or whatever you happened to type.

6. Now press Enter.


Actual results:

Instead of taking you to the URL shown in the location bar, Firefox will take you to the site that you moused over!


Expected results:

When a site in the drop-down is highlighted, the url in the location bar should be updated like when the sites in the drop-down are selected with the arrow keys.
Component: Untriaged → Location Bar
OS: Linux → All
Hardware: x86_64 → All
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043584
OS: All → Linux
OS: Linux → All
You need to log in before you can comment on or make changes to this bug.