If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[MADAI][Multimedia] System crash when playing MP4A-LATM audio type over RTSP

RESOLVED DUPLICATE of bug 1049241

Status

Firefox OS
RTSP
RESOLVED DUPLICATE of bug 1049241
3 years ago
3 years ago

People

(Reporter: Jaemin Song, Assigned: ethan)

Tracking

unspecified
2.1 S4 (12sep)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LibGLA,TD89245,91214,WW,A] [p=1])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

Steps to reproduce:

Execute web browser and play RTSP Streaming link.
1. To play RTSP link, connect "rtsp://125.141.31.147:554/QE/Coverage20130826/R003_3gp_mpeg4(sp@l1@qvga@452kbps@15fps)_aac-lc(96kbps@32khz@2ch).3gp"
2. If I try to play repeatedly, FireFoxOS will be occurred reboot symptom.




Actual results:

It does crash we perform re-play on this clip.
This issue is related with Bug 1049235's comment 2.
Please refer Bug 1049235.(comment 2).
(Reporter)

Updated

3 years ago
Whiteboard: [LibGLA,TD89245,WW,B]
(Reporter)

Comment 1

3 years ago
Dear Ethan,

I have opened new case for reboot symptom.
Please confirm this case.

Thanks.
Flags: needinfo?(ettseng)
(Assignee)

Comment 2

3 years ago
Thanks Jaemin!
I'll take this bug.
Assignee: nobody → ettseng
Flags: needinfo?(ettseng)
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 3

3 years ago
Created attachment 8475834 [details]
gdb_backtrace.log

The gdb backtrace output when the crash happens.
(Assignee)

Comment 4

3 years ago
Media Attribute (a): rtpmap:97 MP4V-ES/1000 ==> AMPEG4ElementaryAssembler
Media Attribute (a): rtpmap:110 MP4A-LATM/32000/2  => AMPEG4AudioAssembler

The crash happens in AMPEG4AudioAssembler::removeLATMFraming(), which is the same as bug 1054230.
(Assignee)

Comment 5

3 years ago
Hi Jaemin,
The link in comment 0 cannot be played since last night (It was fine in the afternoon yesterday).
Could you help to check the status of streaming server?
(Reporter)

Comment 6

3 years ago
I have checked streaming playback.
The link in comment 0 is palyed well.

Thanks.
(Assignee)

Comment 7

3 years ago
(In reply to Jaemin Song from comment #6)
> I have checked streaming playback.
> The link in comment 0 is palyed well.

It seems UDP packets are blocked since last night.
When I play this link now, the RTSP client would fail back to TCP-interleaved RTP and the transport speed is pretty slow (even with VLC player) and hard to debug.
Could you check the firewall policy on this server and do some adjustment?
(Reporter)

Comment 8

3 years ago
I can not control server.
I have just checked RTSP Streaming using comment 0 URL.
I have checked link again using my private phone.
Link is played well.
Sorry that I am not being helpful.
(Assignee)

Comment 9

3 years ago
(In reply to Jaemin Song from comment #8)
> I can not control server.
> Sorry that I am not being helpful.
Jaemin, can you send me the clip through email?
(Reporter)

Comment 10

3 years ago
(In reply to Ethan Tseng [:ethan] from comment #9)
> Jaemin, can you send me the clip through email?

I have sent the clip through email.
Please confirm your email
And could you check the link again?

Thanks.
(Reporter)

Updated

3 years ago
Whiteboard: [LibGLA,TD89245,WW,B] → [LibGLA,TD89245,91214,WW,B]
(Reporter)

Updated

3 years ago
Whiteboard: [LibGLA,TD89245,91214,WW,B] → [LibGLA,TD89245,91214,WW,A]
(Reporter)

Comment 11

3 years ago
Dear Ethan,

I have found same reboot symptom using below link.
Link: rtsp://125.141.31.186:81/Tellme.wmv

As you know, FireFox OS does not support this link's type.
If I try to play the link, browser should pop-up "unsupported type" message.
But when I try to play the link, device is occurred reboot symptom.
When symptom is occurred, I have found below error log.

gecko/netwerk/protocol/rtsp/rtsp/ARTSPConnection.cpp:655 CHECK(IsRTSPVersion( AString( response->mStatusLine, space2 + 1, response->mStatusLine.size() - space2 - 1))) failed. 

Reproducible rate: 100%

I am not sure that this symptom is same with comment 0 case.
If issue is different, I'll create another case.
Please confirm this issue with above link.

Thanks
Flags: needinfo?(ettseng)
(Assignee)

Comment 12

3 years ago
(In reply to Jaemin Song from comment #11) 
> I have found same reboot symptom using below link.
> Link: rtsp://125.141.31.186:81/Tellme.wmv
> 
> As you know, FireFox OS does not support this link's type.
> If I try to play the link, browser should pop-up "unsupported type" message.
> But when I try to play the link, device is occurred reboot symptom.
> When symptom is occurred, I have found below error log.
> Reproducible rate: 100%
> 
> I am not sure that this symptom is same with comment 0 case.
> If issue is different, I'll create another case.
> Please confirm this issue with above link.

Yes. This is a completely different issue.
We had fixed a similar issue while playing MP3 over RTSP (bug 1009497, crashed while playing MP3 over RTSP).
Let me file a new bug for this one.

BTW, please not VLC player and Android phone cannot play this link "rtsp://125.141.31.186:81/Tellme.wmv" either. They handle the error gracefully by showing an error message.
Flags: needinfo?(ettseng)
(Reporter)

Comment 13

3 years ago
(In reply to Ethan Tseng [:ethan] from comment #12)
> BTW, please not VLC player and Android phone cannot play this link
> "rtsp://125.141.31.186:81/Tellme.wmv" either. They handle the error
> gracefully by showing an error message.

Yes. This link is not played.
Problem is just reboot symptom.
I'll file new bug for this(comment 11).

Thanks.
(Assignee)

Comment 14

3 years ago
(In reply to Jaemin Song from comment #13)
> Yes. This link is not played.
> Problem is just reboot symptom.
> I'll file new bug for this(comment 11).

Alright. I see the new bug, thanks.
(Reporter)

Comment 15

3 years ago
Dear Ethan,

Could you share the progress status for this issue?

Thanks.
(Assignee)

Comment 16

3 years ago
(In reply to Jaemin Song from comment #15)
> Dear Ethan,
> Could you share the progress status for this issue?
> Thanks.
I tried to reproduce this bug using my own streaming server and the clip you sent to me.
But it's not feasible this way.
The audio payload type generated by DarwinStreamingServer is different from the one you 
used (XenonStreamer).
XenonStreamer: MP4V-ES + MP4A-LATM
DarwinStreamingServer: MP4V-ES + mpeg4-generic

The crash occurred in the assembler of MP4A-LATM. So I cannot debug with DarwinStreamingServer.

Secondly, our office LAN encountered a problem that UDP (which RTP is carried over) cannot be
transported last week. This issue was fixed last Friday.

I will get back debugging using the link you provided. Thanks.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Summary: [MADIA][Multimedia] When RTSP Streaming playback, detected reboot symptom. → [MADIA][Multimedia] System crash when playing MP4A-LATM audio type over RTSP
Duplicate of bug: 1049241
(Assignee)

Updated

3 years ago
Whiteboard: [LibGLA,TD89245,91214,WW,A] → [LibGLA,TD89245,91214,WW,A] [p=1]
Target Milestone: --- → 2.1 S2 (15aug)
(Assignee)

Updated

3 years ago
Target Milestone: 2.1 S2 (15aug) → 2.1 S4 (12sep)
(Assignee)

Updated

3 years ago
Summary: [MADIA][Multimedia] System crash when playing MP4A-LATM audio type over RTSP → [MADAI][Multimedia] System crash when playing MP4A-LATM audio type over RTSP
(Assignee)

Comment 18

3 years ago
(In reply to Ethan Tseng [:ethan] from comment #16)
> (In reply to Jaemin Song from comment #15)
> > Dear Ethan,
> > Could you share the progress status for this issue?
> > Thanks.

Hi Jaemin,
This bug is resolved fixed by the patch of bug 1049241.
Could you help to verify it? Thanks!
Flags: needinfo?(jaemin1.song)
(Reporter)

Comment 19

3 years ago
(In reply to Ethan Tseng [:ethan] from comment #18)
> Hi Jaemin,
> This bug is resolved fixed by the patch of bug 1049241.
> Could you help to verify it? Thanks!

I have checked your patch.
After applying your patch,
crash was not occurred.
Problem is fixed.

Thank you for your help.
Flags: needinfo?(jaemin1.song)
(Assignee)

Comment 20

3 years ago
(In reply to Jaemin Song from comment #19)
> After applying your patch,
> crash was not occurred.
> Problem is fixed.
> Thank you for your help.
You are welcome.
Thanks for your verification. :)
You need to log in before you can comment on or make changes to this bug.