Closed Bug 1056419 Opened 6 years ago Closed 5 years ago

Sandboxing Mac plugin breaks Fake Video Encoder

Categories

(Core :: WebRTC: Audio/Video, defect)

33 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1055308

People

(Reporter: ekr, Unassigned)

Details

The Sandboxing code causes the fake video encoder not to load.

Probable suspect:
otool -L /Users/ekr/dev/gecko/gecko-dev/obj-x86_64-apple-darwin12.5.0/dom/media/gmp-plugin/libfake.dylib
/Users/ekr/dev/gecko/gecko-dev/obj-x86_64-apple-darwin12.5.0/dom/media/gmp-plugin/libfake.dylib:
	@executable_path/libfake.dylib (compatibility version 1.0.0, current version 1.0.0)
	/System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 19.0.0)
	/usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 228.0.0)
	/System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox (compatibility version 1.0.0, current version 1.0.0)
	/System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHandling (compatibility version 1.0.0, current version 10.0.0)
	@executable_path/libmozglue.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 56.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 169.3.0)

Removing the sandbox activation code in GMPChild.cpp fixes the problem.
Steven,

What is the status of this?
Flags: needinfo?(smichaud)
I suspect this might be the same as what was found on this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1054704#c24

Where the OSX version can't follow a symlink to load the fake gmp plugin.
I think I've already fixed this at bug 1055308.
Flags: needinfo?(smichaud)
The patch in bug 1055308 seems to fix this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1055308
You need to log in before you can comment on or make changes to this bug.