[Calendar][AutoChangeDateTime] Wording and layout are not correct when end date/ time set before start date/ time

RESOLVED DUPLICATE of bug 1054718

Status

Firefox OS
Gaia::Calendar
P2
normal
RESOLVED DUPLICATE of bug 1054718
4 years ago
4 years ago

People

(Reporter: edchen, Assigned: evanxd)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8476535 [details]
This is not toast message

[Devices]
Flame

[Environment]
Gaia      3584b2723412ed3299c6761f465885d80651c87e
Gecko     https://hg.mozilla.org/mozilla-central/rev/e7806c9c83f3
BuildID   20140820160201
Version   34.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[STR]
1. Go to Calendar - add new event
2. Set start time
3. Set end time 
4. Save event
5. Go back to the event and press edit
6. Set end date before before start date
7. The layout is not fulfill UX spec
8. Set end time before start time
9. The wording is not correct.

[Actual results]
1. @step 7: The spec is not display toast message
2. @step 9: (1) This is not toast message (b) The wording is "End date must come after ....."

[Expected Results]
1. This is a toast message
2. The word size is not correct
3. The wording is not correct when end time before start time

[Attachment]
1. This is not toast message
2. Wording issue when set end time before start time
(Reporter)

Comment 1

4 years ago
Created attachment 8476536 [details]
Wording issue when set end time before start time
(Reporter)

Comment 2

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Priority: P3 → P2
QA Contact: edchen
evanxd is already taking care of the wording on Bug 1054718, not sure about the "toast" design.
(Assignee)

Comment 4

4 years ago
Thanks, Miller.
I will check the "toast" design with Harly and Edward.
(Assignee)

Updated

4 years ago
Assignee: nobody → evanxd
Flags: needinfo?
(Assignee)

Updated

4 years ago
Flags: needinfo?
(Assignee)

Comment 5

4 years ago
Hi Harly,

Do you think the "toast" thing is an issue?

Thanks.
Flags: needinfo?(hhsu)

Comment 6

4 years ago
Hi Evan & Edward,
The toast design in the spec is the new toast design for Building Blocks targeted for 2.2 or maybe later. So for 2.1, the current toast is correct, and is not an issue. Sorry for the misunderstanding here.
Flags: needinfo?(hhsu)
(Reporter)

Comment 7

4 years ago
Thanks for Harly confirmation.
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

4 years ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1054718
You need to log in before you can comment on or make changes to this bug.