Closed Bug 1056783 Opened 7 years ago Closed 7 years ago

[shadow-dom] Styles fail to apply with detached host node

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1025724

People

(Reporter: wilsonpage, Unassigned)

References

Details

When the a shadow-root is created on a host that is *detached* from the DOM, styles fail to apply. Styles only apply if the shadow-root is created when the host is *in* the DOM.

TEST-CASE

http://wilsonpage.github.io/shadow-dom/detached-host/
We need to somehow bind shadow dom elements to document when host is bound to document.
(And need to make sure specs actually define this behavior.)
Any movement on this? Is it on a roadmap somewhere?
Is this different from bug 1025724?
Depends on: 1025724
Sounds like it's the same issue
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025724
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.