[FTE] Time and timezone setting is shown in FTE when SIM card is only inserted in slot 2 in flame

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::First Time Experience
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: gchang, Assigned: tedders1)

Tracking

unspecified
2.1 S3 (29aug)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
### Steps:
1. Power off Flame device
2. Insert a SIM card on slot 2
3. Power on Flame device
4. Open Settings
5. Go to Developer > Launch First Time Use
6. Keep clicking Next until "Select a network" 

### Expected:
The "Date & Time" should not be shown after "Select a network" page

### Actual:
The "Date & Time" is shown after "Select a network" page

### Reproduce rate
always

### Version:
Device    flame
Gaia      3584b2723412ed3299c6761f465885d80651c87e
Gecko     https://hg.mozilla.org/mozilla-central/rev/e7806c9c83f3
BuildID   20140820160201
Version   34.0a1
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Is this a dupe of bug 1052486?
Flags: needinfo?(gchang)
Whiteboard: [systemsfe]
(Reporter)

Comment 3

4 years ago
Hi Michael, 
I'm not sure. But, if I put SIM card in slot 1 and repeat the steps in comment #1, the "Date & Time" is not shown after "Select a network" page.
Flags: needinfo?(gchang)
Assignee: nobody → tclancy
blocking-b2g: 2.1? → 2.1+
(Assignee)

Comment 4

4 years ago
Created attachment 8480189 [details] [review]
Check all available mobile connections (SIM 1 & 2) for timezone information.
Attachment #8480189 - Flags: review?(fabien)
Attachment #8480189 - Flags: review?(fabien) → review?(arthur.chen)
Comment on attachment 8480189 [details] [review]
Check all available mobile connections (SIM 1 & 2) for timezone information.

Looks good to me, thanks.
Attachment #8480189 - Flags: review?(arthur.chen) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/846e17e365792c496496b7cc53363a31dc5b92a0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S3 (29aug)
(Reporter)

Comment 7

4 years ago
Verified @
Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED

Updated

4 years ago
status-b2g-v2.1: fixed → verified

Comment 8

4 years ago
Created attachment 8525153 [details]
video of verify issue

This issue can't repro on Flame 2.1
See attachment: verify_video.mp4
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141118001204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141118.035447
FW-Date         Tue Nov 18 03:54:58 EST 2014
Bootloader      L1TC00011880
You need to log in before you can comment on or make changes to this bug.